
DPA-400 

DisplayPort™ 

AUX Channel 

Monitor 

USER MANUAL 



 About This Manual  

2 

Copyright 
This manual © 2021 Unigraf Oy. All rights reserved 

Reproduction of this manual in whole or in part without written permission of  

Unigraf Oy is prohibited.  

Notice 
The information given in this manual is verified in the correctness on the date of issue. The 

authors reserve the rights to make any changes to this product and to revise the information 

about the products contained in this manual without an obligation to notify any persons about 

such revisions or changes. 

Edition 
DP AUX Channel Monitor User Manual, Version 12 

Date: 13. September 2021 

Company information 
Unigraf Oy 

Piispantilankuja 4 

FI-02240 ESPOO 

Finland 

Tel. +358 9 859 550 

info@unigraf.fi 

https://www.unigraf.fi/ 

http://www.unigraf-china.cn 

Trademarks 
Unigraf and DPA are trademarks of Unigraf Oy. 

DisplayPort™ and the DisplayPort™ logo are trademarks owned by the  

Video Electronics Standards Association (VESA®) in the United States and other countries. 

HDCP is a trademark of Digital Content Protection LLC. 

USB™, USB Type-C™ and USB-C™ are trademarks of USB Implementers Forum Inc. 

Windows® 10, Windows® 8, Windows® 7 and Windows® XP are trademarks of  

Microsoft Corporation. 

All other trademarks are properties of their respective owners. 



 About This Manual  

3 

Table of Contents 
Quick Start Guide ............................................................................................. 4 

1. About This Manual ........................................................................................... 5 
2. General ............................................................................................................ 6 

Introducing the DPA-400 .................................................................................. 6 
Functionality in a Nutshell ................................................................................ 7 

DPA-400 Versions ................................................................................ 8 
3. Setup Instructions ............................................................................................ 9 

Contents of the Delivery ................................................................................... 9 
Product Setup .................................................................................................. 9 

Installing the DPA-400 .......................................................................... 9 
GUI Setup ...................................................................................................... 10 

Selecting the COM Port Used ............................................................. 10 
Adding the License Key ...................................................................... 11 
Upgrading the License ........................................................................ 12 

DPA-400 Firmware Upgrade .......................................................................... 13 
4. Data Aquisition ............................................................................................... 14 

Getting Ready ................................................................................................ 14 
The Main Window .......................................................................................... 15 
Controlling the Acquisition.............................................................................. 16 

Starting and Stopping Data Acquisition .............................................. 16 
Monitored Signals ............................................................................... 17 

Acquiring Data ............................................................................................... 18 
Decoding the Data ......................................................................................... 19 

Determining Sink and Source Role ..................................................... 19 
Inspecting the Acquired Data ......................................................................... 20 

Lines ................................................................................................... 20 
Columns ............................................................................................. 20 
Message Details ................................................................................. 22 
Filtering ............................................................................................... 23 

Customizing the Main Window ....................................................................... 25 
Selecting Data Columns ..................................................................... 25 
Selecting Font and Colors .................................................................. 25 
Transaction List Color Options............................................................ 25 
Highlighted DPCD Address Ranges ................................................... 26 
Searching for Data .............................................................................. 27 

5. Saving Your Data ........................................................................................... 28 
Saving to a Binary File ................................................................................... 28 
Creating a Test Report ................................................................................... 28 
Test Report Views .......................................................................................... 29 

Appendix A: Specifications ............................................................................................. 31 
General ............................................................................................... 31 
Interfaces ............................................................................................ 31 

Appendix B: I/O Connector ............................................................................................. 32 
Appendix C: Advanced Filters ......................................................................................... 33 



 About This Manual  

4 

Quick Start Guide 
If you feel confident with installing new hardware and software in your PC you can attempt 

this simplified version of Unigraf DP AUX channel monitor (DPA-400) setup procedure 

Serial Communication and License Key Setup 

 Run the DPA-400 Setup installer 

 Plug the USB connector of the DPA-400 to one of the USB ports in your PC. 

 Launch the DPA-400 GUI (DP_AuxMon.exe) 

 Indicate the DPA-400 unit in the combo-box and click Try Connection. 

 Insert the 32 character long License Key in the field provided and click Continue.  
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1. ABOUT THIS MANUAL 

This manual introduces you to the installation and use of the Unigraf DP AUX Channel 

Monitor DPA-400. The purpose of this document is to: 

• Provide instructions on how to install the provided software. 

• Give an overview of the DPA-400 and of its features. 

• Guide to the DPA-400 typical usage. 

Product Versions 
Functionality and operation described in this manual is related to software release 2.1. Please 

contact Unigraf for details about other versions or refer to the version specific release notes.  

Notes 
On certain sections of this manual, when important information is given, text is formatted as 

follows. Please read these notes carefully. 

Note This text is an important note 
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2. GENERAL 

Introducing the DPA-400 
The Unigraf DP AUX Channel monitor is a compact, pocket-sized device that provides a full 

DisplayPort™ AUX channel traffic analysis. DPA-400 and its Windows GUI tool enable the 

user to monitor, capture, parse and document all messages sent by DisplayPort™ source, sink 

or branch devices. 

Each message is shown as time stamped raw data and in its decoded form, expressed with the 

same terminology used by the DisplayPort™ standard specification. Also, the activity of the 

Hot Plug Detect (HPD) signal and optionally other external signals is tracked and documented 

by a time stamp marking each of its changes of state. 

Easy to Use 

The DPA-400 is a USB-powered device and measures only 10.5 x 13 x 3.5 centimetres, 

making it an ideal tool for a laboratory desktop and a snappy companion for a laptop computer.  

DPA-400 preserves signal integrity by bypassing the Main Stream data lanes with the provided 

special cable. DPA-400 can be inserted between a sink and a source without needing any 

custom adapters or expensive pods. 

Benefits 

• Device independent 

• Data documented with time stamps 

• Pocket Size 

• USB controlled and powered 

Applications 

• Tool in solving interoperability issues 

• Essential partner with Link compliance testing 

• Software debug and validation 

• Documentation of functionality and protocol implementation 

• Monitoring and time measurement of events 



 General  

7 

Functionality in a Nutshell 
The DPA-400 is meant to be connected between a DisplayPort™ source and a DisplayPort™ 

sink device or two USB-C ports with DisplayPort Alternate Mode capability in order to detect 

and record the AUX channel communication between them. The DPA-400 does not take part 

to the communication but transparently monitors the AUX channel traffic, the HPD (Hot Plug 

Detect) line and three external digital inputs. 

The user can select to start the acquisition manually or on a specific transition (rising edge or 

falling edge) of one or more of the external inputs or of HPD. The user can also terminate the 

acquisition manually or on a different transition of the same input signals. 

When the acquisition is enabled, each AUX channel transaction detected is stored in the DPA-

400 internal memory and marked by a timestamp, starting from the time instant the acquisition 

begun.  

The user can also select one or more of the external input signals or the HPD for being 

monitored. Every logical state change of the monitored signals is recorded together with the 

timestamp of when it happened. This is very useful, for instance, to know when HPD gets 

asserted and how long time each HPD pulse issued has taken. 

The GUI application is used to control the acquisition start and stop, to select the monitored 

signals and to browse through the acquired data in a user-friendly fashion. The DPA-400 

features a large internal memory that can quickly collect a huge amount of data. The user can 

download the data stored in the DPA-400 memory to the GUI as soon as it gets acquired or can 

pause the download to first inspect the already visible data. The download can be paused and 

restarted any number of times or aborted if the acquired data is not of interest. 

After the acquisition is stopped, the downloaded data can be saved in binary format or as a 

portable HTML report. In its binary form, the saved data can only be opened by the DPA-400 

GUI while in HTML format it can be opened with any available HTML browser. 
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DPA-400 Versions 

There are multiple versions of DPA-400. All versions share the same test equipment hardware, 

but more recent versions of the DPA-400 GUI support later versions of DisplayPort DPCD 

register structure and other more advanced features. Please see the table below. 

Version Added features 

DPA-400 DPCD 1.X, HDCP 1.X decoding 

DPA-400 1.2 DPCD 1.2 decoding, Sideband CH messages 

DPA-400 1.4 DPCD 1.4, HDCP 2.2 decoding 

DPA-400 2.0 DP 2.0 support for DPCD 1.4 decoding, including DSC, FEC and 
LTTPR specific DPCD registers 

DPA-400 2.1 Added eDP 1.5 support. 

 

DPA product delivery contains a custom Y-shaped cables for use with DP 1.2 and later 

versions. The custom cables bypass the main links outside DPA-400 as shown in the 

illustration on the previous page. 

Note: Please use the custom cable supplied with DPA-400 when monitoring DisplayPort version 1.2 

and higher. DPA-400 hardware is not compatible with the HBR2 and higher main link bit rate. 

The custom cable bypasses main links outside DPA-400. 

 

Note: DPA-400 detects the sink and source role by default from the way how they are connected to 

DP Input (Source) and DP Output (Sink). When Connection independent sink / source 

detection in Decoding pull-down menu, role is detected from the transaction messages. 

Connect to  
DP Source / 
DFP_D 

Connect to  
DP Sink / 

UFP_D 

N.B. Cables with DP 
Connector and USB-C 
Connector are provided 
separately 



 Setup Instructions  

9 

3. SETUP INSTRUCTIONS 

Contents of the Delivery 
The DPA-400 installation SW package includes the following items: 

• DPA-400 Setup installer (DPA-400 Setup.exe) 

• Firmware updater utility (UUFUpd.exe) 

• Latest DPA-400 firmware (*.uuf) 

• Release notes (DPA-400_release_notes.txt) 

• This manual 

 

DPA-400 delivery also includes custom cables for monitoring DisplayPort versions 1.2 and 

above and DisplayPort Alt mode over USB-C interface. 

• DP to DP Y-cable 2 meters (P/N 546098) 

• DP to DP Y-cable 0.5 meters (for high link rates) (P/N 546118) 

• USB-C to USB-C Y-cable 1 meter (P/N 546109) (ordered separately). 

Product Setup 
The DPA-400 unit features an USB to serial conversion controller. Therefore, its Windows 

driver will be installed as a virtual serial port named as a DPA-400 USB Serial Port. Please, 

use the USB Serial Port driver installed by DPA-400 installer. 

Note: System administrator's privileges are required for performing the installation. 

Installing the DPA-400 

In order to install the DPA-400 software and driver please follow these steps: 

 Power up your PC 

 Open the folder containing DPA-400 installation package 

 Run DPA-400 Setup.exe found in the installation package 

 In the Choose Components dialog please indicate if you need the device drivers to be installed 

at this time. 

 In the following dialogs, indicate the folder where the files will be installed and the Start Menu 

folder for the program shortcuts. 

DPA-400 software and firmware will now be installed to your PC. 

 Plug in the DPA-400 unit in a vacant USB port of your PC 

 Run DP-Aux Channel Monitor application 
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GUI Setup 
In order to enable the DPA-400 graphical user interface (GUI) application to communicate 

with the firmware in the DPA-400 unit, you have to set up the COM port used and provide the 

license code delivered with the unit. 

Selecting the COM Port Used 

 From the GUI pull down menu in the center of the GUI and select the serial port used for 

communicating with the DPA-400. It will in most cases be named as DPA-400 USB Serial Port 
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Adding the License Key 

You will need a hardware specific license key for using Unigraf DPA-400 GUI. Each license is 

valid for one specific device only. By using the GUI, you can read the Seed Number of your 

DPA-400 unit. For a given Seed Number, Unigraf will provide you a License Key that will 

enable you to use the GUI from any PC to control your DPA-400 GUI, the user can select the 

interpreted DPCD registers based on the DP version. 

 You can usually find your DPA-400 License Key on a sticker glued on its enclosure, in the 

delivery package or among its related documents. If you cannot locate the License Key, please 

email to Unigraf the Seed Number shown on the dialog in order to receive your License Key. 

 Insert each of the 32 character long License Key in the field provided and click the Continue. 

The license key is now saved in your PC and you can constantly use the device from this PC. 

Please Click Close to return to the main window. 
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Upgrading the License 

For upgrading your license, please select Decoding > Enter new license. In the license entry 

dialog, please type in or copy and paste the new license and click Continue. 

Note Please note that each Unigraf DPA-400 GUI license is bound to one specific DPA-400 unit. 

The same license can be used with any number of PCs. 

 

Note Please note that various features of DPA-400 are enabled with license keys. For upgrading 

your DPA-400, please contact Unigraf. 

 

Note The License Key never includes characters I, G, B, O because of their similarity with the 

corresponding numbers. If in doubt, please use numbers. You can use copy and paste to insert 

the License Key. 

 

Note The DPA-400 must be connected to your PC for entering the License Key. 
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DPA-400 Firmware Upgrade 
When launching the GUI, it will verify that the firmware programmed in the DPA-400 unit is 

matching the GUI version. If upgrade is needed the GUI will prompt the user to update the 

firmware. 

Please follow these steps in order to upgrade your DPA-400 internal firmware: 

 Unplug the DPA-400 USB cable. 

 With a length of wire, short-circuit pins 1 and 6 of the digital I/O connector. Try to make a 

good contact by inserting at least ½” of bare conductor in each of the connector pin holes. 

 

  Plug the DPA-400 USB cable to your PC.  

 Locate the COM port used by your DPA-400 (for instance, COM3). 

 Open Windows command prompt dialog and go to the directory where the installer copied the 

firmware files. (by default c:\Program Files (x86)\Unigraf\DPA-400\ Firmware). In this 

directory you should find the updater, UUFUpd.exe, and the FW file, e.g. dpa-400.uuf. 

 In Windows command prompt run: 

uufupd -c 3 -f dpa-400.uuf  

(In the entry, please substitute “3” with the number of your COM 

port and “dpa-400.uuf” with the firmware file included in your 

package)  

 The UUFUpd utility will upgrade the DPA-400 firmware while printing a series of dots. Please 

wait for its completion without removing the USB cable. 

 When the message “DONE” is printed, please remove the short-circuit from the I/O connector 

and unplug the USB cable. Your DPA-400 is now upgraded with its latest firmware. 

In case you receive an error message from the UUFUpd utility, please restart the above 

procedure from its very beginning (USB cable unplugged) and verify that the short-circuit you 

use makes a good contact and to the right pins. 

 

 

Note After a firmware upgrade, the DPA-400 USB cable must be unplugged and plugged once for 

the device to be again functional.  
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4. DATA AQUISITION 

Unigraf DP AUX Channel Monitor consists of DPA-400 unit for connecting to the 

DisplayPort™ link and a Graphical User Interface (GUI) application for operating it and 

creating reports. The serial communication setup and License Key entry are covered in the 

Setup Instructions section of this manual. The following sections describe the process of 

acquiring AUX channel data. Generating data reports is covered in its own chapter.  

Getting Ready 
Plug your DPA-400 to your PC and start the GUI application. Verify that the right COM port is 

selected, a valid License Key is available and the GUI main window opens. 

If required, connect your external input signals to the DPA-400 I/O connector using a suitable 

cable. 

Note In order to ensure the signal integrity of high main data lane speeds (HBR2 and higher) you 

will need to use the custom Y-shaped pass-by cable supplied with the delivery of DPA-400 or 

the Upgrade package. DPA-400 hardware is not compatible with HBR2 and higher data 

transfer speed. 

 

Note: DPA-400 detects the sink and source role by default from the way how they are connected to 

DP Input (Source) and DP Output (Sink). When Connection independent sink / source 

detection in Decoding pull-down menu, role is detected from the transaction messages. 
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The Main Window 
The GUI main window is divided into two sections. The Transaction list in the left displays 

the acquired AUX channel transactions and events. The Message details panel on the right 

side of the window shows the interpretation of the currently selected AUX channel transaction 

line. The Start acquisition button controls the start and stop of the data acquisition. The 

Status line at the bottom of the window shows the current GUI state, the amount of data 

already downloaded to it and the amount of data still stored in the DPA-400 internal memory 

(buffered) and waiting for downloading. 

Note Please note that the Filters function found in the Main Window in some previous versions of 

the GUI can now be found as a pull down menu. Its function is described later in this 

document. 
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Controlling the Acquisition 
The start and stop conditions of the data acquisition and monitoring of optional signals can be 

defined in the corresponding dialogs. Please consult Appendix B to find out how these external 

signals can be connected to your DPA-400. 

Starting and Stopping Data Acquisition 

By default, the data acquisition is started immediately after the Start acquisition pushbutton in 

the Main window is pressed. Additional conditions can be set in the Start triggers dialog. 

 Select Tools -> Start triggers…  

By default the Start acquisition immediately option is selected. By deselecting it you can 

select one or the more of the advanced options: 

• Start on the rising or falling edge of HPD signal 

• Start on the rising or falling edge of IN0 signal 

• Start on the rising or falling edge of IN1 signal 

• Start on the rising or falling edge of IN2 signal 

The acquisition will start after the Start acquisition pushbutton is pressed and when any of the 

selected conditions is verified. 

Data acquisition can be manually stopped at any time by pressing the Stop acquisition 

pushbutton in the Main window. Optionally, the acquisition can be stopped automatically when 

one of the enabled stop conditions is verified. 

 Select Tools -> Stop triggers…  

You can select one or the more of the advanced options: 

• Stop on the rising or falling edge of HPD signal 

• Stop on the rising or falling edge of IN0 signal 

• Stop on the rising or falling edge of IN1 signal 

• Stop on the rising or falling edge of IN2 signal 
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The acquisition will stop automatically when any of the selected conditions is verified. 

Monitored Signals 

In addition to the AUX channel traffic, you can also monitor the status of four digital signals. 

By default, only the HPD signal is monitored. In the Monitored signals dialog, you can include 

also one or more of the external digital signals IN0, IN1 and IN2. 

 Select Tools > Monitored signals… 

The dialog allows you to select the monitored signals. 
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Acquiring Data 
 Plug your source and sink devices to the DPA-400 as described in section Getting Ready of this 

chapter. 

 Select the signals to be monitored or check that the HPD is selected. 

 Check the start and stop triggers. 

 Finally press the Start Acquisition button. 

The GUI automatically enables data download and data is displayed in the Transaction List as 

soon as it is acquired and reaches the GUI. From the Status line at the bottom of the Main 

window you can monitor the amount of downloaded data and how much data is still waiting to 

be downloaded. 

Usually, the buffered data amount always read as zero, meaning that all the acquired data has 

been downloaded to the GUI. When a quick and long sequence of transactions is acquired or 

when a rapidly toggling external input is monitored, the DPA-400 internal buffer can fill-up 

much more rapidly than what the GUI can download. 

 If the DPA-400 buffer gets filled with a large amount of data, you can pause the download by 

pressing the Pause Download pushbutton. 

 After inspecting the downloaded data, you can decide to resume the download to gather more 

data by pressing the Download pushbutton. 

 If the acquisition is not stopped automatically by one of the selected stop triggers, you can 

force its termination by pressing the Stop Acquisition pushbutton. 

 

Note Restarting the data acquisition clears the DPA-400 internal buffer and the GUI downloaded 

data! 
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Decoding the Data 
There are multiple versions of DPA-400. All versions share the same test equipment hardware, 

but more recent versions of the DPA-400 GUI support later versions of DisplayPort DPCD 

register structure and other more advanced features. Please see the table below. 

Version Added features 

DPA-400 DPCD 1.X, HDCP 1.X decoding 

DPA-400 1.2 DPCD 1.2 decoding, Sideband CH messages 

DPA-400 1.4 DPCD 1.4, HDCP 2.2 decoding 

DPA-400 2.0 DP 2.0 support for DPCD 1.4 decoding, including DSC, FEC and 
LTTPR specific DPCD registers 

DPA-400 2.1 Added eDP 1.5 support. 

 

From the pull-down menu select Decoding and select the version. 

You can select: 

• DPCD 1.1 Decoder 

• DPCD 1.2 Decoder 

• DPCD 1.3 Decoder 

• DPCD 1.4 Decoder for DP 1.4a 

• DPCD 1.4 Decoder for DP 2.0 

• Define if DETAILED_CAP_INFO_AVAILBLE bit (DPCD 0x00005) is set to indicate that 

DFP capability field is 4 bytes/port for the detailed capability description 

• Define if MAIN_LINK_CHANNEL_CODING_SET (DPCD 0x00108) is set to 2 to indicate 

128b/132b Link Layer 

Note Please note that various features of DPA-400 are enabled with license keys. For upgrading 

your DPA-400, please contact Unigraf.  

Determining Sink and Source Role 

DPA-400 detects the messages sent by sink and source by default from the way in which 

connectors they are connected. The device connected to ‘DP Input’ is determined as Source 

and the device connected ‘DP Output’ is determined as Sink.  

When normal DP cable connection is not used, or when the direction cannot be otherwise 

determined reliably, user can select Connection independent sink / source detection in 

Decoding pull-down menu. In this case message source is detected from the payload of 

transaction message by identifying payload items belonging to messages sent by a source and 

sink respectively. 
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Inspecting the Acquired Data 
The data acquired by the DPA-400 and downloaded to the GUI is shown in the Transaction 

list. Please refer to chapter Customizing the Main Window below for details on how to modify 

the content and look of the Transaction list. 

Lines 

The data is organized in lines, each numbered starting from 1 and marked with a timestamp. 

There are four kinds of lines: 

1. Information lines 

Identified by the text “INFO” in their Type column, they provide some useful information like 

the time acquisition has started and stopped or the logical state of the inputs, etc. 

2. Transaction lines 

Identified by the text “Native” or “I2C” in their Type column, they report an AUX channel 

data transfer, either a data Request or a data Reply. 

3. Event lines 

Identified by the text “Event” in their Type column, they signal the state change in one or more 

of the monitored inputs. 

4. Sideband Channel Messages 

The Isochronous Transport Service uses the sideband communications over sideband channel 

(AUX CH and HPD) for the management of topology/virtual channel connection/Main Link 

and performs Main Link symbol mapping. 

5. Error lines 

A line Type reading “Error” marks the detection of an illegal AUX channel data packet. An 

irregular start condition, an irregular stop condition or transfer of a number of bits which is not 

a multiple of 8 are all conditions that cause an error line. 

6. Trace lines 

Combines the data from several lines of a HDCP related message to one entry in Message 

details panel for easier readability. 

 

Columns 

The data on each line is ordered in columns. Each column provides additional information 

about the data line, facilitating its viewing and interpretation: 

Line 

This column displays the line number, starting from 1, and cannot be hidden. 

Timestamp 

Each line is identified by its timestamp, marking the instant when an event or error was 

detected, or when a data transaction got started. The timestamp can be displayed as a time 

delay from the start of the acquisition (absolute) or from the previous line (relative). The 

timestamp can be displayed in milliseconds or in minutes, seconds and microseconds. 
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From 

This column indicates the originator of the data line: 

• “Source” and “Sink” for an AUX channel transaction, respectively a data 

Request and a data Reply. 

• “Source Trace” and “Sink Trace” respectively for Sideband Message data 

Request and Reply. 

• “DPA-400” for error and information lines. 

• “Unknown” for signal state change events. 

Type 

This column provides additional information about the type of the line: 

• “Native” marks Native AUX channel Requests and Replies. 

• “I2C” marks I2C AUX channel Requests and Replies. 

• “Sideband Request” and “Sideband Reply” to mark the Sideband Channel 

messages 

• “Event” is used for signal state change events. 

• “INFO” is used with information lines. 

• “Error” is used for illegal conditions detected on the AUX channel. 

Details 

This column contains an abbreviated description of the line content in textual form. 

Data 

The binary data exchanged during AUX channel transactions, in hexadecimal notation. 

 

Note Please make sure that you have connected the DP cables right: 

DP Source >> DP Input, DP Output >> DP Sink Device 
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Message Details 

The Message details panel is used to provide a detailed explanation of the line currently 

selected in the Transaction list. For AUX channel transaction lines, for each of the DPCD 

memory locations affected, the panel lists: 

• All data bytes read or written. 

• All DPCD memory locations affected. 

• The name of the locations and of each of their bit fields. 

• All bit field’s numeric and binary values, together with their decoded value. 

• The Replies outcome (AUX_ACK, AUX_NACK, I2C_DEFER, etc.). 
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Filtering  

In the Filters drop down menu you can set up rules describing which data lines are shown in 

the Transaction List. You can choose the data based on: 

• The type of data line 

• The origin of the message 

• The DPCD address range 

In the Filters drop down menu you can find by default a set of pre-programmed filters. 

The Custom Filter dialog provides you a possibility to add and modify new filters. The pre-

programmed filters are listed in the dialog. You can copy their structure as bases of your 

custom filters. It is advisable not to modify the pre-programmed filters directly but make 

copies of them. 

In the Stored custom filter definitions panel, you will have the list of currently defined Filters. 

On the right hand side buttons, you can define new Filters, rename, or delete them. You can 

also reorder their appearance in the Filters pull-down menu. 

In the Filter Rules panel lower in the dialog, you can review and change the Rules in the 

selected Filter. By clicking Add… you can create new rules, clicking Edit… you can review 

and edit existing Filters and by clicking Remove from the Filter definition. 

When you click Add… or Edit… Edit Filter Rule dialog opens. In the dialog you can in detail 

define the action of the rule, select the event and the event details. 

You can get help by clicking Help. The “Help” text is attached to Appendix C of this 

document. 
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Note Please note that Filters are a very powerful tool. They can however unintentionally hide 

valuable data from you. Please be careful when applying custom filters. 

A good practice is to start from an existing filter and gradually add new rules while testing 

their performance.  

 

Note  Filtering and selecting the columns for display do not affect the actual data acquisition. All 

transactions and their full data are always captured. 

 

Note You can recall the default filters by deleting or renaming Filters.ini file stored in configuration 

file location (default c:\ProgramData\Unigraf\DPA-400). When DPA-400 GUI is restarted, a 

new Filters.ini file will be created. 
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Customizing the Main Window 
You can change the format of the data shown in the Transaction list and the Message details 

panels in order to highlight the details of your interest. 

Selecting Data Columns 

You can customize the Transaction list by clicking the right button of your mouse over the list. 

From the pop-up menu, you can choose which columns to display, the style of the timestamp 

and switch between absolute and relative timestamps.  

Selecting Font and Colors 

You can select the font style and size used for displaying the Transaction list and the Message 

details. 

Select Tools -> Options ... . In the Options dialog press Select new font and choose the font 

that you want to use.  

Transaction List Color Options 

You can select the colors for the font and background of various items. 
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Highlighted DPCD Address Ranges 

In order to improve the readability of the Transaction list, you can mark the AUX channel 

transactions where a certain DPCD register address or address range is accessed with a color of 

your choice. 

 Select Tools > Options ... . In the Option dialog press Add…. 

 In the New range dialog select the access type, start address and end address of the range that 

you want to be colored. Press Accept. 

 Select the range you just created from the Colored addresses ranges list and click the Font 

Color and Background Color buttons to select the colors desired. 

You can create multiple simultaneous coloring rules to help you get a better view of the data 

captured. 

Note The data of Transaction List Color Options and Highlighted DPCD Address Ranges is stored 

in Windows registry under 

HKEY_CURRENT_USER\Software\Unigraf\DPA_400B\_ProgramConfig_. By using the 

Regedit tool you can copy the settings to another PC or under another user. 
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Searching for Data 

You can search and highlight all lines in the Transaction list representing an AUX channel 

access to a selected DPCD location. 

 Use Search -> Find… or press Ctrl + F. In the Search dialog select the access type and the 

DPCD location address that you want to search. 

The first occurrence of the found access is selected and the rest are highlighted.  

 After a new acquisition you can use the same search criteria and select  

Search -> Find again or just press F3. 
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5. SAVING YOUR DATA 

After the acquisition is stopped, the data displayed in the Transaction list can be saved to a file 

in binary format or in a readable HTML format as a report. In its binary form, the saved data 

can only be opened by the DPA-400 GUI while in HTML format it can be opened with any 

available HTML browser. 

Saving to a Binary File 
From the pull down menu select File -> Save or File -> Save As … and specify the name for 

the file to be saved. You can reload a previously saved file for later inspection using File -> 

Load. 

The DPA-400 GUI application includes a report generator that creates a test report of the 

results displayed in the Results Grid. The report is generated in HTML format and includes a 

detailed description of the test steps executed, the actions taken and the causes of the pass or 

failure. You can also include detailed description of the monitored source and sink and the used 

TE in the report. 

Creating a Test Report 
The report generated by the GUI application includes all the lines from the Transaction list and 

the content of the Message details panel for each of them. For creating a report select from the 

pull down menu File -> Save Report ….  

After selecting the report file name, in the Report Information dialog you can add a description 

of the monitored source and sink devices, and your personal remarks that will be included in 

the report. 
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Save the report by clicking Accept or return to the main window without saving by clicking 

Cancel. After the report is saved, your default internet browser will be opened to display the 

report file created. 

The information entered in the dialog fields will be available also for the following reports 

until the GUI is closed. 

Note  You can create reports from previously acquired data that has been saved in binary format. Use 

first File -> Load and then File > Save Report …. 

Note  Report creation for large amounts of acquired data can generate large HTML files and take 

several minutes. During this operation the GUI will not respond to user commands. Please, be 

patient. 

Test Report Views 
When you save a report file or open a previously saved report, your internet browser will open 

the report default view. 

Note how each time you select a report line the transaction details at the left shows a lot of 

useful information about the data involved. 
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In order to print the report, scroll down and click the Show printer friendly format… 

pushbutton to get a new view formatted for an easy printing. 
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APPENDIX A: SPECIFICATIONS 

General 

Functionality Real-time AUX channel traffic capturing, decoding and display. 
Data store and reload in binary format. 
HTML report generation. 
Internal 14 MByte capture buffer. 
AUX transactions as fast as 0.5 ms per transaction (Request + 
Reply). 
Input state changes monitored up to 8000 changes / s. 
Timestamps with 32 µs resolution. 

  

Operating Systems Windows® 10, 8, 7 

  

Mechanical size 105 x 130 x 35 mm 

Weight 260 grams 

Power Consumption 5 V, 400 mA 

Interfaces 

DisplayPort™ Interfaces One DisplayPort™ receptacle input connector. 

One DisplayPort™ receptacle output connector. 

AUX channel and HPD signals pass-through. 

DPA-400: Main stream lanes buffered with 1:1 amplification 
(maximum bandwidth 2.7 Gbps).  
Pin 20 (DP_PWR) pass-through 

DPA-400 1.2 and later: Main stream lanes by-passed with the 
provided cable.  
Pin 20 (DP_PWR) not connected 

Custom I/O  Sub-D 9 socket (female). 

3 trigger inputs, link HPD signal. 

4 expansion outputs. 

ESD protection on all external signals. 

PC Interface USB interface, USB-powered. 

Software upgrade capability through USB 

  

Trigger inputs 5V tolerant. 
3.3V CMOS input levels. 
IEC 61000-4-2 (ESD) 8kV (air), 6kV (contact) 

DisplayPort™ signals IEC 61000-4-2 (ESD) 8kV (air), 6kV (contact) 

 



 Appendix B: I/O Connector  

32 

APPENDIX B: I/O CONNECTOR 

You can use three external trigger signals to start or stop the data acquisition. The trigger 

signals are available on the SubD-9 socket connector of the DPA-400. Please refer to the 

Start triggers and Stop triggers dialogs to control the triggers functionality. 

The HPD_IO signal is also available on this connector to provide you an easy measurement 

access to the HPD signal driven by your DisplayPort™ sink and connected to your 

DisplayPort™ source device. 

 

 

Pin Signal Name Direction 

1 IN0 Input 

2 IN1 Input 

3 IN2 Input 

4 HPD_IO Output 

5 OUT0 Output 

6 OUT1 Output 

7 OUT2 Output 

8 OUT3 Output 

9 GND - 
 

 

IN0: external input trigger 0. 

IN1: external input trigger 1. 

IN2: external input trigger 2. 

HPD_IO: HPD signal common to the DisplayPort sink and source devices. 

OUT0 – OUT3: for future expansions. 

GND: electrical reference ground. 
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APPENDIX C: ADVANCED FILTERS 

The following help text can be seen as well by clicking the Help button of the Edit Filter Rule 

dialog. 

Note Please note that Filters are a very powerful tool. They can however unintentionally hide 

valuable data from you. Please be careful when applying custom filters. 

A good practice is to start from an existing filter and gradually add new rules while testing 

their performance.  

 

Note  Filtering and selecting the columns for display do not affect the actual data acquisition. All 

transactions and their full data are always captured. 

Data pattern expressions 

A data-pattern expression is a string that describes how to determine if a data-block should be 

considered as "matched" or "unmatched". The syntax used with data-pattern expressions in 

DPA-400 Aux Channel Monitor application is described below 

The data-block must be covered completely by the data-pattern expression. If the data block is 

shorter, or longer than the expression, then the data block is determined as "not matched". The 

'*' wildcard can be used to allow data blocks of any size to match. 

Whitespaces and new-lines are ignored, and are allowed anywhere; White spaces and new-

lines can be used strategically to make the expression more readable. 

For example: "*!(10)??(10)" is the same as "* ! (10) ? ? (10)" 

Comment blocks: 

Comments must be written enclosed in curly-braces '{' and '}'. 

Wildcards 

Wildcards used are '*' and '?' 

? = Match any single data byte only. 

* = Match any number of any data bytes. (including the possibility of matching NO data bytes) 

For data matching, the byte value must be enclosed in braces '(' and ')'. Use prefixes '$' to 

indicate HEX value, '%' to indicate BIN. No prefix indicates DEC. 

Examples: 

* ($10) ($00) : Matches any data pattern that has the bytes $10, $00 at end of data. 

? ($10) ($00) : Matches 3-byte data pattern that has $10 as second byte and $00 as third byte. 

* ($10) * ($00) : Matches any data pattern that has $10 and ending to a $00 byte. 

* ($10) * ($00) * : Matches any data pattern that has $10 and $00 after it. 

($10) ? * ($20) * : Matches any data pattern that has $10 as first byte, followed by $20 with at 

least one other byte in between. (i.e. will not match $10, $20) 

Use '!' to invert the match: 

!($00) = Match any data byte that isn't $00. 

Use '?' within HEX or BIN value to ignore that bit in comparison: 

($??) = ? = Any data Byte. 
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($?0) = Any data byte with bits 0-3 cleared. 

(%1???????) = Any data byte with bit 7 set. 

(%0??????1) = Any data byte with bit 7 cleared and bit 0 set. 

The '!' inversion can still be used: 

!(%??????00) = Matches any data byte ending to %10, %11, %01 but not %00. 

To match a single data byte with more than one value, separate the values with comma ',': 

(0, 1, 100, 200, 254) : Matches a data byte whose value is 0, 1, 100, 200 or 254. 

Invert the value group match with '!'. Value wildcard '?' is also allowed. 

Example: 

!(1, 2, 3) : Match any data byte other than 1, 2 or 3. 

!($?f, $f?) : Don't match data bytes with bits 0-3 set to 1, or data bytes that have bits 7-4 set. 
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