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Quick Start Guide 
This is a reduced version of the CTS tool configuration. If you feel quite confident with 
installing new hardware and software in your PC you can attempt this procedure. 

Serial Communication Setup 
 Copy the dpctsgui.exe tool into your PC 

 Connect a COM output or a USB to COM converter cable to the SubD9 connector of 
the DPT-200 or the SubD9 connector on the DP adapter of the VTG-5225. 

 Notify the COM port that your PC is using for the communication with the TE. 

 Power up the TE. 

 Launch the Tool 

 Select Tools > Options and in the dialog select the COM port that your PC is using. 

Verifying the Firmware Version 
 From the pull down menu select Tools > Firmware Update … . 

 Click the Check Running Version to verify the version number of the firmware 
loaded. 

 If you need to upgrade the firmware select the new *.hex file and click Upgrade. 

 After the upgrade is complete reset the DP transmitter. 

Adding the License Keys 
 Select Tools > Add License(s).  

 Insert each of the 32 character long License Keys in the field provided and click Add 
License button.  
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1. GENERAL 

About This Manual 
This guide introduces you the installation and use of Unigraf CTS Test Tool for 
DisplayPort™ Reference Source. Please refer to the relevant VESA Compliance Test 
Standard for the description of the requirements and pass criteria for each test. 

The purpose of this guide is to 

• Give an overview of this DisplayPort™ CTS Test Tool and its feature. 
• Give instructions for the user on how to install the tools and the load 

related firmware to the TE. 
• Introduce the use of the tool. 

Product Versions 
This manual introduces functions in the following software versions. Please contact 
Unigraf for details.  

 Version Issued 
UGDP RefSource    

Firmware (FW) UGDPSource_x.x.x.hex TBD 
User Interface (GUI) dpctsgui.exe v.1.1.21 29.9.2008 

Notes 
On certain sections of the manual, when important information or notification is given, 
text is formatted as follows. Please read these notes carefully. 

Note This text is an important note 
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2. INTRODUCTION 

Unigraf VTG-5225 DP 
VTG is a family of video pattern generators with RGB, DVI, LVDS, Composite, 
Component and DisplayPort™ output. VTG was the first PC based pattern generator 
which was introduced first as PC bus cards and later as USB connected and stand alone 
version. VTG-5000 series pattern generators provide deep color and high pixel rate 
signals on various output formats. VTG-5225 DP is a DisplayPort™ Reference Source 
compatible with Unigraf DP CTS tools. 

Unigraf DPT-200 
DPT-200 is a compact sized yet full featured DisplayPort™ Reference Source. It is 
controlled and powered by a PC through a USB connection. DTP-200 is compatible 
with Unigraf DP CTS tools. 

Unigraf DisplayPort™ Reference Sink and  
Reference Source CTS Tools 

Unigraf’s DisplayPort™ Reference Source CTS can be used with the DP Video Test 
Generator VTG-5225-DP while the Reference Sink CTS can be operated on either the 
DPR-100 DP sink or the UFG04-DP DP Frame Grabber. 

Both CTS tools feature a graphical user interface that provides the user diagnostic 
functionalities and controls for performing the actual test. The tools also generate the 
reporting. The Reference Source CTS includes both the Link Layer and the HDCP 
compliance tests.  

The tools consist of two components: the Windows graphical user interface (GUI) 
application, and the target firmware for the DisplayPort™ controller (FW) on the Test 
Equipment. The actual tests are implemented by the FW, while the system control and 
the status reporting are done by the GUI. The GUI and the FW are communicating 
using a serial interface. The FW implements both the functions needed in the CTS test 
and the normal functionality as DP video generator or frame grabber. 

Unigraf Reference Source CTS Tool 
Unigraf’s Reference Source CTS Tool can be used either with VTG-5225 DP or 
DPT-200 units (commonly called Test Equipment, TE). The functionality is identical 
between the two devices. The CTS software is connected to both devices by using a 
RS-232 connection. A separate USB to serial conversion cable can be used if the USB 
connection of the PC needs to be used. 
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Reference Source Block Diagram 
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3. SETUP INSTRUCTIONS 

Contents of the Delivery 
Unigraf’s CTS Tool for DisplayPort™ Reference Source delivery includes the 
following items: 

• The Graphical User Interface (GUI) dpctsgui.exe  
• The DPRX Firmware (FW) UGDPSource_x.x.x.hex 
• Release notes UGDPRefSource_release_notes.txt 
• This manual 

Communications Setup 
The communication between the the CTS Tool GUI and the firmware located in the DP 
output card of the test equipment (TE) is done by using a RS-232 serial communication 
channel. The tool will assign the right communication parameters but you have to 
indicate it which COM port your PC is using. 

 Connect a COM output or a USB to COM converter cable to the SubD9 connector of 
the DPT-200 or the SubD9 connector in the DP adapter of the VTG-5225. 

 From Windows Device Manager notify the COM port that Windows has assigned to the 
communication. In case when using a USB to Serial Converter please select the one 
marked as USB Serial Port.  
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GUI Setup 
The graphical user interface (GUI) of the CTS Tool is dpctsgui.exe executable. It can 
be just copied to your PC and does not need any special installation. You can run it 
directly from the folder by double clicking the icon. 

Setting up the Communication 
 From the pull down menu select Tools > Options … and select the communication port 

for communicating with the TE. In field Time-Out you can define the time-out delay in 
the tests. In field Delay between tests the time the tool pauses after starting a new test. 
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Updating the DPTx Firmware 
The firmware (FW) for the DisplayPort™ source controller (DPTx) resides in the Test 
Equipment, i.e. the VTG-5225 DP or the DPT-200. The actual tests are implemented by 
the FW, while the system control and the status reporting are done by the GUI. The FW 
implements both the DPTx functions needed in the CTS test and the normal 
functionality as DP video generator. 

The DPTx firmware version can be verified and the firmware can be updated by using 
the Firmware Upgrade dialog. 

 From the pull down menu select Tools > Firmware Update … . 

 Click the Check Running Version to check the version number of the firmware loaded. 

 Click the click the ellipsis button (…) to browse for an firmware update file and click 
Upgrade to start loading the code. You can monitor the status of the upgrade process in 
the Status panel in the lower part of the dialog. 

 After the upgrade is complete. Push the DP Reset button on the VTG-5225 DP or 
DPT-200 unit. Click OK to return to the main dialog. 

Adding the License Code 
Unigraf CTS tools software are license protected. Each license is valid for one test 
equipment (TE) hardware only. By using the CTS GUI you can read the Product Seed 
Number of the TE. For a given Seed Number, Unigraf will provide you a License Key 
that enables you to use the software in any number of PCs to control the given TE. 

 Open the License Manager from the pull down menu by selecting Tools > Add 
License(s).  

 Please provide Unigraf the Product Seed Number shown on the bottom of the dialog 
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 Insert each of the 32 character long License Keys in the field provided and click Add 
License button. The license keys are now stored in your PC and you can constantly use 
the TE in the PC. Please Click Close to return to the main dialog. 

 

Note Please note that each Reference Source CTS software license is bound to one specific 
Unigraf Test Equipment (TE). Several licenses e.g. LL CTS and HDCP CTS can be 
validated at the same time. The license can be used with any number of PCs when they 
are using this specific TE. 

 
 

Note The License Key never includes characters I, G, B, O because of their similarity with 
the corresponding numbers. If doubt, please use numbers. You can use copy and paste 
to insert the License Code. 

 
 

Note The TE must be connected when entering the License Key. 
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4. USING THE CTS TOOL 
The user interface of Unigraf CTS Tool for DisplayPort™ Reference Source provides 
the following four main functions: 

• Optionally the Sink Tests or HDCP Tests or both 
• EDID tool 
• DPCD Access 
• Link Training status 
• Report generator 

The supporting tools for serial communication setup, firmware updates and license code 
entry are covered in section Setup Instructions in this manual. 

The following chapters describe the controls found in the five main dialogs. The report 
generator is described in its own section. The actual testing is described in chapter 
Running the CTS Test. 

Two Separate Parts 
Unigraf DP CTS tests are divided into two separate sets: DP Link Layer tests and DP 
HDCP tests. The license key can include one set or both sets combined. The following 
images show the structure of the tool tabs when only DP LL CTS tests are enabled and 
when both the DP LL and HDCP tests are enabled. 

Tool with only Link Layer tests enabled 

Tool with Link Layer and HDCP tests enabled 
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Status Panel 
You can follow the communication between the firmware in the TE and the test tool on 
the Status Panel on the lower part of the dialog. All test steps and reasons for Pass or 
Fail will be indicated here. The contents of the Status Panel will be copied also to the 
Test Report. You can clear the contents of the panel by clicking Clear Status. You can 
hide the panel by clicking the Hide Status. 

Note Please note that the test steps will still be showed on the report even if the Status Panel 
is cleared. 

Link Layer Tests Dialog 
For performing the Link Layer (LL) CTS Test for the Sink DUT devices select the Link 
Layer Tests tab. 

List of Tests 
The list of test on the right hand side of the dialog contains all 26 DP LL CTS tests 
indicating the corresponding chapter in VESA Link Layer Compliance Test Specification 
and the name of the test as it is mentioned in the specification. Place the mouse cursor 
on top of the name to see it in full. The Results Grid includes counters for: Pass, Fail, 
Skip, Timeout and Status.  

You can select a test either by clicking a mouse or by moving up or down in the list 
with the Up and Down arrow keys in the keyboard. Home key selects the first test and 
End key the last test. You can select multiple consecutive tests by holding down the 
Shift key while selecting and multiple individual tests by holding the Ctrl key while 
selecting. 



 DP Reference Source CTS Tool User Manual  

Preliminary 14  

Test Control 
By using the test controls on the left side of the dialog you can Select All tests, Clear 
Results Grid of all tests, define how many times the Test Runs are repeated. Pressing 
Run Tests starts the test sequence and press the same key again to Abort the sequence. 

DUT Capabilities 
In the DUT Capabilities panel on the lower left side of the panel you can limit the 
timing and Calorimetric values used during testing. 

In order to set the timing used during the testing select the Fixed Timing checkbox. 
Click Edit … to set the used timing. 

To limit the Colorimetric values used during the testing click the DUT Colorimetry 
Support  and in the dialog check the rows matching the Format, Bit Depth, Dynamic 
Range and Color Coefficient that you want to use. 
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HDCP Tests Dialog 
For performing the HDCP CTS Test for the Sink Devices select the Sink Tests tab. 

List of Tests 
The list of tests on the righ side of the dialog contains all DP HDCT CTS tests 
indicating the corresponding chapter in VESA HDCP Compliance Test Specification and 
the name of the test as it is mentioned in the specification. Place the mouse cursor on 
top of the name to see it in full. The Results Grid includes counters for: Pass, Fail, Skip, 
Timeout and Status.  

You can select a test either by clicking a mouse or by moving up or down in the list 
with the Up and Down arrow keys in the keyboard. Home key selects the first test and 
End key the last test. You can select multiple consecutive tests by holding down the 
Shift key while selecting and multiple individual tests by holding the Ctrl key while 
selecting. 

Test Control 
By using the test controls on the left side of the dialog you can Select All tests, Clear the 
Results of all tests in the test grid, define how many times the Test Runs are repeated. 
Pressing Run Tests starts the test sequence and press the same key again to Abort the 
sequence. 

DUT Capabilities 
For description of DUT capabilities panel please refer to description of Link Layer 
Testing Dialog above. 
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EDID Dialog 
For evaluating and modifying the EDID (Extended display identification data) of Sink 
Devices select the EDID tab. 

Controls 
By using the controls on the left hand side of the dialog you can do the following tasks: 

You can read the EDID information from a Sink by clicking the Query From Device 
button. You can also program the currently shown EDID information to the Sink by 
clicking the Write to Device button. 

You can Load an EDID hex file from a file in your PC and you can Save the EDID 
information from a Sink as a hex file. 

Hide or show the EDID Hex view by toggling button Hide HEX View. 

Note Please note that the EDID information that is programmed into the Sink will replace the 
EDID information in the device. Doing this might change the way that Source devices 
operate when connected the Sink. Please be careful when using this function 

EDID HEX contents 
This panel shows the EDID information in raw hexadecimal notation. 

EDID Decoder 
This panel shows the contents of the EDID in clear text. By selecting one of the items 
on the left hand panel, the right hand panel shows the contents decoded. 
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Link Training Dialog 
In order to see the link training status select the Link Training tab. 

Click Update Status to show the result of the previous Training. Click Start Training 
to initiate a new Link Training using the configuration given in the Link Configuration 
controls.  

Link Configuration 
With Link Configuration panel you can set the parameters for the Link Training.  

With Line Count you can select a maximum lane count of either 1, 2 or 4 lanes.  

With Link Rate you can select a maximum rate of either High 2.7 Bbps or 
Low 1.62 Gbps.  

With Link Symbol Clock you can select either Asynchronous or Synchronous clock 
mode. 

With the two check boxes you can enable the Data Scrambling and Lane Skew. 

Source / Sink Status 
The panel shows the link configuration agreed by the Sink and the Source during the 
Link Training. Please refer to VESA DisplayPort Specification for description of the 
options for each item. 



 DP Reference Source CTS Tool User Manual  

Preliminary 18  

DPCD Read / Write 
DPCD Read / Write dialog enables you to reading and writing the contents of the 
DisplayPort™ Configuration Data registers (DPCD). From the pull down menu select 
Tools > DPCD Access ….  

Write the address of the DPCD register in field Source / Target Address:. For reading 
the register contents click Read. For updating the register contents write the new value 
to field Data: and click Write. For returning to the main dialog, click Close.  

Please note that the DPCD register address and data and the contents are written and 
given in hexadecimal notation. E.g. “206” means 0x206. 
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5. TEST REPORT 
The tool includes a report generator that creates a test report of the results displayed in 
the Results Grid. The report is generated in HTML format. The reports include detailed 
description of the steps of the test, the actions taken and the causes of the pass or failure. 
You can also include detailed description of the DUT and the used TE in the report. 

Note Please note that by clearing the Result Grid, you will clear also the Test Report  

Creating a Test Report 
For creating a report select from the pull down menu File > Save Report ….  

The Addional Data for Report dialog provides you fields for entering the reference data 
of the TE and the DUT that will be included in the report. The left column is for DUT 
date and the right column for the TE. 

In the Additional Comments field you can describe other items that you want to include 
in the report. This could be remarks of the testing situation etc. 

Save the report on the disk by clicking Save Report or return to main dialog without 
saving by clicking Cancel. The report will be saved to the path and file name specified 
in the bottom of the dialog. After the report is saved, your default internet browser will 
be opened and the report file opened in that. 

The information entered in the fields of the Addional Data for Report dialog will be 
available for follow-on reports until the tool is closed. 
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Test Report Views 
The internet browser will open the report in the Test Summary view. This view provides 
you a similar test summary that is shown on the  Sink Tests tab of the CTS tool. It 
summarizes all performed tests and their Pass, Fail, Time out or Skipped status. The 
background of the status list is coloured red if the test does not have Passed status. 

The Contents bar on the left side of the report is an active quick selection toolbar for 
showing the five (5) views of the report. 

Click Test Summary to get back to this initial view. 

Click General Information to show the information given on the Additional Data for 
Report dialog.  

Click View all test details to show all information for the progress and results of all 
tests. 

The Contents bar also contains a list of active links for showing the detailed results by 
test. Click one of the tests listed under View details by test to show the details if one 
test at a time. You can select this view also by clicking one of the test titles in the Test 
Summaryview. 

Click Printer Friendly for formatting the report for printing. 
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General Information View 
This view provides only the data from Additional Data for Report dialog 

All Test Details View 
This view provides the detailed procedures of the test and test result description for all 
the performed tests. The horizontal title bar of every test indicates the status of the test. 
Green if passed, Red if not passed. 
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Details by Test View 
This view provides the same information as the All test details view but only for the 
selected test. 

Printer Friendly View 
This view will remove the side toolbar and includes the General Information and All 
Test Details into one report for printing. To get back to the Test Summary View click the 
Back button of your internet browser. 


