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Trademarks 
Unigraf and UFG are trademarks of Unigraf Oy. 

 

Windows XP, Windows are trademarks of Microsoft Inc. 
Intel and Pentium are trademarks of Intel Corporation.  

All other trademarks are properties of their respective owners. 

Limited Warranty 
Unigraf warrants its hardware products to be free from defects in workmanship and 
materials, under normal use and service, for twelve (12) months from the date of 
purchase from Unigraf or its authorized dealer. 

If the product proves defective within the warranty period, Unigraf will provide repair 
or replacement of the product. Unigraf shall have the whole discretion whether to repair 
or replace, and replacement product may be new or reconditioned. Replacement product 
shall be of equivalent or better specifications, relative to the defective product, but need 
not to be identical. Any product or part repaired by Unigraf pursuant to this warranty 
shall have a warranty period of not less than 90 days, from the date of such repair, 
irrespective of any earlier expiration of original warranty period. When Unigraf 
provides replacement, then the defective product becomes the property of Unigraf. 

Warranty service may be obtained by contacting Unigraf within the warranty period. 
Unigraf will provide instructions for returning the defective product. 

CE Mark 
The VTG-5225 unit meets the essential health and safety requirements, is in conformity 
with and the CE marking has been applied according to the relevant EU Directives 
using the relevant section of the corresponding standards and other normative 
documents. 
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QUICK START GUIDE 
This is a reduced version of the Software and Driver CD Installation procedure. If you 
feel quite confident with installing new hardware and software in your PC you can 
attempt this procedure. 

WinVTG and DLL Software Installation 
 Start your PC 

 Insert Unigraf VTG Installation CD in your PC 

 WinVTG installation will start 

Windows USB Driver Installation 
 Connect the provided USB cable to VTG-5225 and to a USB port in your PC 

 Power up VTG-5225 

 Make sure that Unigraf VTG Installation CD is inserted 

Using WinVTG 
 Start WinVTG and select the VTG-5225 device by double clicking the icon on the left 

hand side panel 

 Use the Timing Tool, Pattern Tool, Palette Tool or Output Control on the top of the 
WinVTG panel for selecting the requested test timing / pattern combination 

 Congratulations. You are ready to start using the VTG-5225 
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1. GENERAL 

About This Manual 
This guide leads you through the installation of VTG Video Test Generators and the 
WinVTG software. It also provides you the general introduction for the functionality. 

The purpose of this guide is to 

• Give an overview of the VTG-5225 test pattern generator and its features. 
• Give instructions for the user on how to install the related software and 

the drivers to the PC. 
• Assist the user in configuring the output signal with the WinVTG tool. 

Product and Driver Version 
This manual introduces functions in the following set of hardware, firmware and 
software versions. You can find this information in the Release Notes of your Unigraf 
VTG Installation Disk.  

 Version Issued 
VTG5k Software Release v. 1.6.4 07.04.2008 

WinVTG3.exe v.3.1.6 07.04.2008 
dpctsgui.exe  v.1.0.3 31.03.2008 
Vtg32.dll  v.6.0.8 02.04.2008 
Vlib32.dll  v.6.0.4 20.03.2008 
vtgpnpserv.exe  v.1.0.1 12.02.2008 
VTG5k SW  v.1.6.5 07.04.2008 
VTG5k FPGA  v.0b.00.0a.04 07.03.2008 
VTGUSB Driver  v.2.0.2 30.11.2007 
USB chip SW  v.1.1.3 12.02.2008 
UG DP Source  v.2.0.0 02.04.2008 

Notes 
On certain sections of the manual, when important information or notification is given, 
text is formatted as follows. Please read these notes carefully. 

Note This text is an important note 
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2. INTRODUCTION 

Unigraf VTG 
VTG is a family of video test pattern generator PCI plug-in boards and independent 
units intended for providing a high quality video test signal for testing video displays, 
flat panels modules and other video equipment. The family includes models for 
sourcing video signal for most display interface types. This manual introduces functions 
found in VTG-5225, a USB connected video pattern generator. 

VTG-5225 Device 
 Block Diagram 

VTG-5225 design is based on an advanced high speed FPGA. The FPGA consist the 
program execution unit CPU, the Drawing engine and the Timing and output control. 
The test patterns are stored in the Frame Buffer and clocked out to Built-in outputs or 
V5K output adapters via the HSIF connector.  

WinVTG user interface or a customer application uses the VTG DLL library. The 
library communicates with the CPU over the USB communication instructing it to 
execute drawing functions, set the timing or perform other tasks. 
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Identifying Connectors 
 The image below shows the built-in connectors of the VTG-5225 device. Each 
V5K output adapter will have its own connections not shown in this image. 

 

WinVTG 
Unigraf WinVTG tool provides powerful, straightforward and illustrative way of 
configuring the VTG devices and their functions. It allows the user to define the full 
details of the output video. 

• Timing of the output signal with detailed adjustments 
• Patterns created by the VTP pattern definition language 
• The optional color palette for use with legacy 256 color patterns 
• The control of the options for various outputs of the unit 

The definitions can be saved in the PC for later use. The tool recognizes individual 
VTG unit type, the V5K output adapter installed and outputs available. It only shows 
the user the controls featured. 

DLL Library 
All functions that can be controlled through the WinVTG tool are also available for 
user applications in the comprehensive DLL library. The DLL library provides a very 
powerful and flexible platform for the designer of a factory automation system. All 
tasks and functions required in display testing can easily be created and automated. 
Please refer to VTG DLL User's Manual for an explanation of the DLL functions. 
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VTG System Information 
Whenever contacting Unigraf for support. Please read and copy the system information 
by selecting Help > About… in the WinVTG pull-down menu. This status panel will 
provide information for the VTG applications installed in your PC and their versions. 

The panel will also list you the VTG devices present in your PC. You can get the Serial 
number, the drivers used to control it the firmware version loaded etc. 

Note When requesting support from Unigraf, please save this information to a file to be sent 
with the problem description. 
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3. INSTALLATION 

Contents of the Delivery 
The VTG-5225 unit delivery includes the following items: 

• VTG-5225 main unit 
• Unigraf VTG Installation CD 
• This manual on the CD 
• USB Cable 
• AC/DC Power Adapter 

Software Setup 
The software installation consists of the installation of the WinVTG tool and the 
installation of the USB communication driver. The installation procedure of the 
WinVTG tool automatically starts when you install the CD. Windows operating system 
installs the USB driver when the VTG-5225 unit is connected to the PC. 

The WinVTG software uses the VTG DLL library for controlling the VTG unit. The 
DLL library will be installed at the same time as the WinVTG software and the user 
does not need to install it separately. It is important that the WinVTG software, the DLL 
library and the USB driver software all have compatible revision. Therefore it is highly 
recommend that you uninstall any previous WinVTG software, VTG DLL libraries and 
VTG drivers before starting this installation. 

Note System administrator privileges are needed for installing new software to your PC. 

 
Note It is highly recommend that you uninstall any previous WinVTG software, VTG DLL 

libraries and VTG drivers before starting this installation. 
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Installation of WinVTG Tool 
 Start the PC and log to the WindowsXP operating system. 

 Insert the VTG Installation CD. The installation utility will start automatically and 
extract the installation package. You can also start the utility manually by selecting Start 
> Run… > d:setup. “d:” indicates the CD drive used. 

 Click Next >, note the copyright information and note the reminder for uninstalling the 
previous versions of the software. 

 Click Next > and read the Release Notes. They explain the changes from the previous 
versions and instruct you if special measures are needed for the installation. Please also 
verify the installed software to the list on Product and Driver Version chapter of this 
document. If they are not the same, please verify the list of changes by scrolling further 
down in the Release Notes. Click Next > 

 The software is by default installed into folder C:\Program Files\Unigraf\. If you want 
to assign another directory then click Change… and in the new dialog select one. Click 
Next > 
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 In the following dialog select either Complete to install all software, example timings 
and example patterns. By selecting Custom you can select which individual 
components you would like to install. You can also see the amount of hard disk space 
will be needed for each individual feature. By clicking Space the tool calculates the 
available storage space on your hard disk. 
Each feature will allow you to specify options for the installation. Please click Help for 
more information. 

 Click Next >  

 The installation is now ready to start. Click < Back to review or chance your selections 
or click Install to start the installation. 
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VTG File Structure 
The installation wizard creates a file structure where each file type is stored within its 
own category and further subcategories. Some of the files will be used during normal 
operation of the WinVTG tool or by the DLL functions. Other files will be needed for 
special tasks only. The folder structure of a Complete installation is the following. 

The WinVTG tool and the DLL libraries will use the following file types. They contain 
settings for video timing, test patterns, palette definitions, and bitmaps. The extension 
defines the type of information stored in each file: 

Extension Name Function 
*. vtt Timing Defines the timing used for the output. The user can create and 

store new timings with the Timing Editor of the WinVTG tool. 
*.vtp Pattern Pattern definition file. Uses a proprietary VTP pattern definition 

language. Can consist of basic drawing instructions, text or 
bitmaps. The user can create and store new palette files with the 
Pattern Editor of the WinVTG tool. 

*.vtc Palette Color look-up table file for the legacy 256-color system. 
The user can create and store new palette files with the Palette 
Editor tool of the WinVTG. 

*.v5kimg Image Bitmap images converted to the proprietary format. The user can 
create and store new palette files with the Bitmap Manager tool. 

*.vtf Font Font files used within the VTP patterns. 
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Installation of the VTG USB Driver 
When WinVTG software installation has been completed, plug in the provided USB 
cable between your PC and the VTG-5225 device and turn on the power (Please refer to 
the explanation of the VTG-5225 connectors in Chapter 2 Introduction of this manual). 
Windows will now recognize the connection of a new device and launch the driver 
installation. 

 In the Welcome to the Found New Hardware Wizard dialog Select  
No, not this time and click Next > 

 Insert the VTG Installation CD, select Install the software automatically and click 
Next > 

 Select Continue Anyway to the warning 

The driver will now be installed in your PC. Click Finish to close the dialog. 

Start the WinVTG tool. You should now have the VTG-5225 visible on the left hand 
side panel of the tool. 
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4. USING WINVTG 
WinVTG is the graphical user interface for configuring and using the VTG devices. 
WinVTG3 is mainly targeted for controlling the USB connected VTG devices 
VTG-4000 series and VTG-5000 series. The VTG-3000 series PCI card products can be 
best controlled with the earlier version of the WinVTG. 

WinVTG user interface utilizes the VTG DLL library to control the unit. All unit 
control functions found in WinVTG, and more, can be found in the VTG DLL library. 
For factory automation the VTG DLL library is the most flexible way of controlling the 
VTG units. Timing and pattern files created with WinVTG can be also called from the 
VTG DLL library. This makes the WinVTG and the VTG DLL library a combination of 
tools that support each other. 

WinVTG3 Main Screen 
WinVTG3 main screen is divided horizontally in two parts. On the left hand panel the 
tool shows the available VTG devices. The topmost device is the 0-Device, a virtual 
device that e.g. lets you examine and modify the timing and pattern files. Below the 
0-device are icons of all other VTG devices present in the PC. When you place the 
mouse cursor on top of a unit, the bottom part of the left hand side panel shows the 
Device Information of that particular unit. 

The Device Information lists the type designation, the serial number, and ADID, the 
identification of the V5K output adapter if one is present. 

You can assign a specific name to each unit by selecting Device > Rename, clicking F2 
or the right mouse button and selecting Rename. You can get the default name again by 
clicking the right mouse button and selecting Reset Device Name. 
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Working with VTG Devices 
You can open any of the devices either by double clicking its icon or clicking the right 
mouse button on top of the icon and selecting Open. The software now initiates the user 
interface, loads the device-dependent settings and initiates the device. The device is 
now ready for use. On the left hand side panel the opened devices have a green radio 
button associated with them. 

Please notice also the Events, Errors and Both information tabs in the bottom of the 
WinVTG Main Screen. In case of abnormal situations, you will see messages here. This 
occurs for example if you are entering incompatible values to the Timing Editor’s fields 
or if your pattern definition file contains syntax errors. 

You can now control the device by using the icons in the top of the right hand side 
Device Screen. They are from left to right: the Timing selector and editor the Color 
Palette selector and editor, the Pattern selector and editor and the Output Control for 
controlling the syncs and other details of the output signals. 

Selecting one of the icons will bring you the associated tool. The tabs below the icons 
and the pull-down menu will change according to the selected tool, providing the 
controls needed for that tool. Please note that the tool is only affecting the selected 
device. The currently selected device is associated with a black dot in the center of the 
green radio button. 

You can close the active VTG device by selecting Device > Close from the top down 
menu or right clicking the mouse and selecting Close. You can restart the VTG device 
for example to clear an abnormal situation by selecting Device > Reset Device from the 
top down menu or right clicking the mouse and selecting Reset Device. 

If you want that WinVTG remembers all timings, patterns and controls that you have 
selected for all open VTG devices next time that you open the WinVTG, please select 
WinVTG > Save state for all opened devices. 
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VTG System Information 
By selecting Help > About… in the WinVTG pull-down menu you can open the VTG 
System Information panel. It will provide information for the VTG applications 
installed in your PC and their versions. 

The panel will also list you the VTG devices present in your PC. You can get the Serial 
number, the drivers used to control it the firmware version loaded etc. 

Note When requesting support from Unigraf, please save this information to a file to be sent 
with the problem description. 
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Timing Tool 
You can select the Timing Tool by selecting the associated icon on the Device Screen. 
The tool has three views: the Timing Editor view, the Timing File Selector view and 
Both views combination view. All three views provide information to the same selected 
timing. 

WinVTG timings are saved in timing files. Each timing file holds the details of one 
specific timing. The file extension of the timing files is *.vtt. The timing files are human 
readable so you can view the information also without the WinVTG tool.  

Note In order to avoid unwanted effects, it is highly recommended that the timing files are 
modified only by using the Timing Editor tool in WinVTG. 

Timing Editor 
The timing editor is the tool for viewing, modifying and creating the *.vtt timing files. 
The File description field on the top of the tool is a free form text definition for the 
timing. The numeric input fields on the left hand side of the tool’s view allows you to 
insert the timing parameters either based on Time and Frequency or by Dots. The right 
hand side of the tool illustrates the various timing parameters in all three forms. 

By defining the parameters based on Time or Frequency the horizontal Active Video, 
and the horizontal and vertical sync and porch timing are expressed in microseconds. In 
Time mode the horizontal and vertical total is expressed in microseconds and milli-
seconds, while in Frequency mode they are expressed in kHz and Hz respectively. In 
both cases the horizontal and vertical resolution is expressed in horizontal dots and 
vertical lines. In the Dots parameter mode all parameters are indicated in horizontal dots 
and vertical rows. 
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Timing File Selector 
In Timing File Selector or Both views tab you can select an existing timing by double 
clicking either the the Filename or the description field or by clicking the OpenFile 
button. Only timings in one file folder of your PC will be shown in the list. For selecting 
an alternative folder either click the ellipsis button (…) for browsing your PC or the 
down arrow for selecting from folders below the timings folder of the WinVTG3 file 
stucture created during the installation.  

If you would like to open the Timing Tool with the Timing File Selector instead of the 
Timing Editor, select the Lock this view open box in the dialog. 

Editing a Timing 
The recommended parameter input order for creating a new timing or modifying a 
timing file is the following. 

 From the pull-down menu select Timing File > New. For editing an existing timing 
double click the file in the file selector view or from the pull-down menu select Timing 
File > Open… 

 First edit the Horizontal Resolution field, and then edit the horizontal Active Video.  

 Edit Horizontal Period. 

 Edit HSYNC Time and the horizontal Backporch. The horizontal fields are now ready. 

 Edit Lines/Field. 

 Edit vertical Resolution and then VSYNC Time and vertical Backporch. 

For sync signal control please refer to the description of the Output control function 
later in this manual. 

If you enter a conflicting value for one of the fields, an error message will be shown on 
the error panel in the bottom of the screen. 
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Pattern Tool 
You can select the Pattern Tool by selecting the associated icon on the Device Screen. 
The tool has three views: the Pattern Editor view, the Pattern File Selector view and 
Both views combination view. All three views provide information to the same selected 
pattern. 

WinVTG patterns are saved in pattern files. Each pattern file holds the details of one 
specific display pattern. The file extension of the pattern files is *.vtp. The pattern files 
are text files so you can view and edit the information also without the WinVTG tool. 
Please refer to VTP Pattern Definition Language Manual for syntax of the VTP 
language. 

Pattern Editor 
Pattern editor allows you to edit the VTP language definition of the pattern and attach a 
bitmap, color palette or font file to the pattern. The whole definition of the pattern, 
except for the bitmap image information is in the VTP pattern file. The File description 
field on the top of the tool is a free form text definition for the pattern. 

After editing the pattern definition click Redraw or press <F4> for updating the 
displayed pattern. The VTP language keywords with their parameters can be selected 
from the pull-down menu in Keyword field. Select one of the commands and click 
Insert Keyword. 

For attaching a bitmap in the pattern click the Attach Bitmap… button and browse for 
the file. You can insert the bitmaps either in the proprietary V5KIMG or VTB formats. 
You can convert PNG files to the V5KIMG format with the Bitmap Manager tool in the 
Tools pull down menu. Please refer to the introduction of the Bitmap Manager later in 
this manual. The VTB format is the legacy format supported by earlier WinVTG 
versions. 

The Palette files are color definition files for Colormode 0. Please refer to their 
description either in VTP Pattern Definition Language Manual or the description of the 
Palette tool later in this manual. 
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Font files are VTF used in the VTP language for drawing text in the pattern. Please refer 
to their description in VTP Pattern Definition Language Manual. 

Pattern File Selector 
In Pattern File Selector or Both views tab you can select an existing pattern by double 
clicking either the the Filename or the description field or by clicking the OpenFile 
button. Only patterns in one file folder of your PC will be shown in the list. For 
selecting an alternative folder either click the ellipsis button (…) for browsing your PC 
or the down arrow for selecting from folders below the patterns folder of the WinVTG3 
file stucture created during the installation. 

For refreshing the list, click the Refresh button. For redrawing a pattern, double click 
the file name. 

If you would like to open the Pattern Tool with the Pattern File Selector instead of the 
Pattern Editor, select the Lock this view open box in the dialog. 
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Palette Tool 
In VTG-5225 the user can assign the drawing colors in two basic ways: either by giving 
the actual Red, Green and Blue (or R, G and B) color component values or using pre-
defined color palettes. The first method is referred as True Color Mode and the latter as 
Palette Mode. 

In True Color Mode the numerical values given for R, G and B will be the actual output 
signal intensity values for the pixel in question. The numerical color value in Palette 
Mode will act as an address (or index) to a pre-defined color in a 256 color table. The 
output signal intensity will be the R, G and B value entry in the cell where the address 
points to. The 256 color table is called “palette”. 

You can select the Palette Tool by selecting the associated icon on the Device Screen. 
The tool has three views: the Palette Editor view, the Palette File Selector view and 
Both views combination view. All three views provide information to the same selected 
palette. 

 

Palette Editor 
The palette editor is the tool for viewing, modifying and creating the *.vtc palette files. 
The File description field on the top of the tool is a free form text definition for the 
palette. 

The colored rectangles with a number each represent one color in the selected palette. 
The number of distinct colors in each palette is 256. Color number 0 (zero) will always 
be black. You can see the rest of the colors by using the scroll bar in the right hand side 
of the panel. The 256 colors can be selected from a total number of 16.7 million color 
shades. 



 23 Preliminary 

Select a color by clicking the corresponding rectangle. You can examine and change the 
intensity of each of the Red Green and Blue component of the color either by using the 
corresponding slider, typing in the value number or using the up and down arrows near 
the number field. Select the slider with your mouse or by pressing the Tab key. Change 
the value of the slider by using the left and right or up and down keys of your keyboard.  

The lowest slider of the Color Adjustment panel sets the color depth of the definition. 
The table below shows the range of Red, Green and Blue for each color depth 

Color Depth 
(Bits) 

Nr of color bits 
per pixel 

Range of values for  
Red, Green and Blue 

6 18 0 to 63 
8 24 0 to 255 
10 30 0 to 1023 
12 36 0 to 4095 

 

The Video Signal Level panel in the bottom of the Palette editor defines the output level 
of the Analog1 and Analog2 outputs. 

You can save the palette by selecting Palette File > Save (Ctrl+S) or Save As… (F12) 
from the pull-down menu. You can create a new palette file with all colors black by 
selecting Palette File > New (Ctrl+N). 

Palette File Selector 
In Palette File Selector or Both views tab you can select an existing palette by double 
clicking either the the Filename or the description field or by clicking the OpenFile 
button. Only patterns in one file folder of your PC will be shown in the list. For 
selecting an alternative folder either click the ellipsis button (…) for browsing your PC 
or the down arrow for selecting from folders below the colors folder of the WinVTG3 
file stucture created during the installation. 

If you would like to open the Palette Tool with the Palette File Selector instead of the 
Palette Editor, select the Lock this view open box in the dialog. 
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Output Control 
You can monitor and control the signaling of the outputs of the VTG-5225 by using the 
Output control dialog. The contents of the dialog will change according to which 
V5k output adapter is mounted in the VTG-5225 unit. The dialog for the built in analog 
and DVI outputs is always present. 

Analog Synchronization Control 
The controls for VTG-5225 built-in analog outputs consist of the synchronization signal 
controls. 

You can set the Horizontal sync options from the HSYNC Output panel, the Vertical 
sync options from the VSYNC Output panel and the Composite sync mode from the 
CSYNC Mode panel. From the Output settings panel you can define where the 
composite sync appears. When Video blanked option is selected, no syncs are present 
in the output. 
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V5k Output Adapter Control 
Each V5k output adapter features its specific output controls. The VTG software 
identifies the adapter type from the Adapter ID and provides the specific outputs for the 
user or the custom SW interface.  

Controls for VTG-5225 DVI 
The following controls are available for the v5k DVI output adapter (Adapter ID = 
$5050). v5k DVI output adapter features a DVI output with HDCP compatibility. It is 
used in VTG-5225 DVI and VTG-5120 DVI products. 

The HDCP encryption can be enabled by selecting Enable HDCP. The HDCP status 
can be seen in the Status window. Status window is opened by clicking the Status icon 
in the top of the right hand side Device Screen. 

The horizontal and vertical sync polarities of the v5k DVI output adapter is controlled in 
the HSYNC polarity and VSYNC polarity fields. 

HSYNC polarity 0 = active low, 1 = active high, 2 = always low, 3 = always high 
VSYNC polarity 0 = active low, 1 = active high, 2 = always low, 3 = always high 

When HDCP is enabled the Status window shows the state of various HDCP status 
flags. The updating of the window can be seen as a blinking marker on the upper right 
hand corner of the panel. 
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Controls for VTG-5225 QLT 
The following controls are available for the v5k quad LVDS output adapter (Adapter ID 
= $5030). v5k quad LVDS output adapter features a four channel LVDS output. It is 
used in VTG-5225 HLV and VTG-5120 HLV products. 

 

HSYNC polarity 0 = active low, 1 = active high, 2 = always low, 3 = always high 
VSYNC polarity 0 = active low, 1 = active high, 2 = always low, 3 = always high 
Reduced_swing LVDS output swing control: when “0” VOD = 350 mV, when “1” VOD = 200 mV 
Mapping_mode LVDS mapping table selected: when “1” Mapping Mode 1 , when “2” Mapping 

Mode 2. See the THine TH63LVD1023 datasheet 
Quad_mode Operation mode selected.  

Mode 0: Standard “single pixel” mode, where all pixel data is output on CH1. 
Data output on CH1 is copied also to CH2 to CH4.  
Mode 1: Standard “double pixel” mode, where all pixel data is output on CH1 
and CH2. First pixel appears on CH1 and second one on CH2. Data output on 
CH1 and CH2 is copied also, respectively, to CH3 and CH4.  
Mode 2: “Quad pixel” mode, where pixel data is output on all four channels. 
First pixel appears on CH1, second one on CH2, third on CH3 and fourth on 
CH4. 

GPO0  General Purpose Output 0: connected to CH2 and CH4 connectors pin 3. 
Logic “0” or “1” 

GPO1 General Purpose Output 1: connected to CH2 and CH4 connectors pin 18. 
Logic “0” or “1” 

GPO2 General Purpose Output 2: connected to CH2 and CH4 connectors pin 9. 
Logic “0” or “1” 

GPO4 General Purpose Output 4: connected to CONT21 bit (7th bit of pair TD of CH2 
and CH4). Logic “0” or “1” 

GPO5 General Purpose Output 4: connected to CONT21 bit (7th bit of pair TE of CH2 
and CH4). Logic “0” or “1” 

 

Please, note that GPO0 to GPO2 are 3V digital CMOS outputs directly available on the 
channel connectors. GPO4 and GPO5, instead, are user programmable data bits that are 
encoded together with the pixel data stream and available at the receiver (LCM) side 
only after being decoded by the receiver chipset. 
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Output pin mapping 
With output pin mapping the order of output color bits can be reconfigured. Output pin 
mapping can be used for bit shifting or e.g. with some LCD modules whose color bit 
order is not consecutive. 

In order to change the output bit order, please enter in the Output value field the 
desired order. 

Example: 

Output value: 9876543210__ all bits shifted with two. Input 10 bits/color output 12 
bits/color. Input data bit 9 is mapped to output data bit B (11, eleven) Two lowest 
output bits are set to GND (logic LOW). 
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APPENDIX A TOOLS 

Bitmap Manager 
The bitmap images used in VTG-5225 have to be converted to the proprietary “v5kimg” 
bitmap format. It is a non-loss format with up to 12 bits per color component. The 
WinVTG Bitmap Manager is a conversion utility form PNG format to v5kimg format. 

 You can launch the Bitmap Manager from the Tools pull-down menu. 

The left hand side panel shows the folder with PNG images to be converted and the 
right hand side shows the contents of the destination folder. Click “…” below each 
panel for selecting the folder 

The sliders in the bottom of the panel and the menus when pressing the right key of the 
mouse are not supported in this version of WinVTG. 

 Click Start conversion for converting the files. 
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APPENDIX B CONNECTORS 

USB Connection 
The VTG USB interface is implemented by using a Cypress CY7C68013A chip. The 
input connector in VTG-5225 unit is a USB B connector. The interface is USB 2.0 
compliant. Data rates: full speed (12 Mbps) or high speed (480 Mbps).  

The pin-out of the USB connector is the following: 

Pin Function Pin Function 
1 WAKEUP 4 GND 
2 DATA- 5 GND 
3 DATA+ 6 GND 

 

Serial Interface 
The VTG Serial interface is a RS-232 compatible interface for control of the VTG-5225 
unit. The instruction set of the serial interface is limited, allowing only some basic 
timing and pattern functions. The baud rate of the interface is fixed at 115200 bps (8, 
None, 1). 

Serial interface has also two special functions:  

(1) By short circuiting pin 2 and pin 3 of the connector while the VTG-5225 unit is 
powered up, the unit starts in Update Mode. Please refer to Appendix C Firmware 
Update. 

(2) The serial interface is used for uploading the USB communication firmware to the 
unit. This task is not necessary in normal firmware update process. It requires 
special instructions and should be done by Unigraf authorized personnel only. 

The pin-out of the serial interface connector is the following: 

Pin n. Function Pin n. Function 
1 NC 6 NC 
2 TX 7 NC 
3 RX 8 NC 
4 NC 9 NC 
5 GND 
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APPENDIX C FIRMWARE UPDATE 
VTG-5225 functionality is created with the combination of the dll library in the PC, and 
the firmware in the VTG-5225 device itself. The firmware controls and performs the 
low level functions of the hardware.  The firmware can be updated using the WinVTG 
tool when the VTG-5225 hardware is started up in a special update mode. In this mode 
the basic pattern generator functions are not functional and the main emphasis is in 
updating the firmware of the device. 

You can verify the latest firmware version from Help > About … panel of the WinVTG. 

Update Mode 
The VTG-5225 is turned to Update mode by short circuiting pins 2 and 3 of the 9-pin 
SubD RS-232 connector for power-up. 

 Short circuit pins 2 and 3 of the RS-232 connector. 

 Start the WinVTG tool 

 Switch on power to the VTG-5225 unit 

Your PC will now detect a new device and will load the driver for that. Please use the 
same driver what was used for the normal operation of the VTG-5225 unit. You will 
find it typically in c:\Windows\Drivers\ or in the VTG installation CD. 

 Click Continue anyway and Next to install the driver. 

You can now see a VTG-5001 device icon in the WinVTG with a special arrow mark 
indicating the update mode.  

 Double click the icon to open the device for updating. 

 On the right hand side of the Firmware file field on the top of the panel click … to 
browse for the .vfc file. 

15
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 Please indicate the location of the file. After WinVTG installation the folder 
C:\Program Files\Unigraf\VTG Firmware Update\VTG-5225\ will contain the latest 
firmware at the time of the release. Please contact Unigraf for the latest version. 

 Click Start update. The firmware will now be loaded from your PC to the VTG-5225 
device and stored in a non-volatile memory. You can follow the process in the Events 
panel of the WinVTG. 

The last message should be Remote update was successful. Your VTG-5225 device 
has now been updated. 

 Power down your VTG-5225 device. When you turn on the device again it is ready to 
be used. Please remember to remove the short circuit from the RS-323 connector. 

 


