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UNIGRAF
Quick Start Guide

If you feel confident with installing new hardware and software in your PC you can attempt
this simplified version of Unigraf DP AUX channel monitor (DPA-400) setup procedure

vvvyyvyy

Serial Communication and License Key Setup

Run the DPA-400 Setup installer

About This Manual

Plug the USB connector of the DPA-400 to one of the USB ports in your PC.

Launch the DPA-400 GUI (DP_AuxMon.exe)

Indicate the DPA-400 unit in the combo-box and click Try Connection.

Insert the 32 character long License Key in the field provided and click Continue.

Unigraf Aux channel menitor
File Search Tools Filters Decoding Help

Please, Enter the your new license key and dick 'Continue'.

Device Seed number

7066330b00000041

License key

 H_H H F H H H
Save License Continue

¥ Cancel

Status  License entry Downloaded 0 Bytes Buffered 0 Bytes
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1. ABOUT THIS MANUAL

This manual introduces you to the installation and use of the Unigraf DP AUX Channel
Monitor DPA-400. The purpose of this document is to:

. Provide instructions on how to install the provided software.
. Give an overview of the DPA-400 and of its features.
. Guide to the DPA-400 typical usage.

Product Versions

Functionality and operation described in this manual is related to software release 2.1. Please
contact Unigraf for details about other versions or refer to the version specific release notes.

Notes

On certain sections of this manual, when important information is given, text is formatted as
follows. Please read these notes carefully.

Note This text is an important note
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2. GENERAL

Introducing the DPA-400

The Unigraf DP AUX Channel monitor is a compact, pocket-sized device that provides a full
DisplayPort™ AUX channel traffic analysis. DPA-400 and its Windows GUI tool enable the
user to monitor, capture, parse and document all messages sent by DisplayPort™ source, sink
or branch devices.

Each message is shown as time stamped raw data and in its decoded form, expressed with the
same terminology used by the DisplayPort™ standard specification. Also, the activity of the
Hot Plug Detect (HPD) signal and optionally other external signals is tracked and documented
by a time stamp marking each of its changes of state.

Easy to Use

The DPA-400 is a USB-powered device and measures only 10.5 x 13 x 3.5 centimetres,
making it an ideal tool for a laboratory desktop and a snappy companion for a laptop computer.

DPA-400 preserves signal integrity by bypassing the Main Stream data lanes with the provided
special cable. DPA-400 can be inserted between a sink and a source without needing any
custom adapters or expensive pods.

Benefits
. Device independent
. Data documented with time stamps
3 Pocket Size
. USB controlled and powered

Applications

Tool in solving interoperability issues

Essential partner with Link compliance testing

Software debug and validation

Documentation of functionality and protocol implementation
Monitoring and time measurement of events
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Functionality in a Nutshell

Source

DD
Sink

The DPA-400 is meant to be connected between a DisplayPort™ source and a DisplayPort™

sink device or two USB-C ports with DisplayPort Alternate Mode capability in order to detect
and record the AUX channel communication between them. The DPA-400 does not take part

to the communication but transparently monitors the AUX channel traffic, the HPD (Hot Plug
Detect) line and three external digital inputs.

The user can select to start the acquisition manually or on a specific transition (rising edge or
falling edge) of one or more of the external inputs or of HPD. The user can also terminate the
acquisition manually or on a different transition of the same input signals.

When the acquisition is enabled, each AUX channel transaction detected is stored in the DPA-
400 internal memory and marked by a timestamp, starting from the time instant the acquisition
begun.

The user can also select one or more of the external input signals or the HPD for being
monitored. Every logical state change of the monitored signals is recorded together with the
timestamp of when it happened. This is very useful, for instance, to know when HPD gets
asserted and how long time each HPD pulse issued has taken.

L w0
| P
AUX Channe < _
» rigger
: < ain Link ; Inputs
I Monitoring
| Interface
[
-
|
DPA-400 1.2 Cable USBI

The GUI application is used to control the acquisition start and stop, to select the monitored
signals and to browse through the acquired data in a user-friendly fashion. The DPA-400
features a large internal memory that can quickly collect a huge amount of data. The user can
download the data stored in the DPA-400 memory to the GUI as soon as it gets acquired or can
pause the download to first inspect the already visible data. The download can be paused and
restarted any number of times or aborted if the acquired data is not of interest.

After the acquisition is stopped, the downloaded data can be saved in binary format or as a
portable HTML report. In its binary form, the saved data can only be opened by the DPA-400
GUI while in HTML format it can be opened with any available HTML browser.
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DPA-400 Versions

There are multiple versions of DPA-400. All versions share the same test equipment hardware,
but more recent versions of the DPA-400 GUI support later versions of DisplayPort DPCD
register structure and other more advanced features. Please see the table below.

Version Added features

DPA-400 DPCD 1.X, HDCP 1.X decoding

DPA-400 1.2 DPCD 1.2 decoding, Sideband CH messages

DPA-400 1.4 DPCD 1.4, HDCP 2.3 decoding

DPA-400 2.0 DP 2.0 support for DPCD 1.4 decoding, including DSC, FEC and
LTTPR specific DPCD registers

DPA-400 2.1 Added eDP 1.5 support.

DPA product delivery contains a custom Y-shaped cables for use with DP 1.2 and later
versions. The custom cables bypass the main links outside DPA-400 as shown in the
illustration on the previous page.

Note: Please use the custom cable supplied with DPA-400 when monitoring DisplayPort version 1.2
and higher. DPA-400 hardware is not compatible with the HBR2 and higher main link bit rate.
The custom cable bypasses main links outside DPA-400.

Note: DPA-400 detects the sink and source role by default from the way how they are connected to
DP Input (Source) and DP Output (Sink). When Connection independent sink / source
detection in Decoding pull-down menu, role is detected from the transaction messages.

jesay  8sn

et
z
2
®
N.B. Cables with DP
Connector and USB-C
Connector are provided
separately
DP Connector
Connect to Connect to
DP Sink / o S DP Source /
UFP_D 5 DFP_D
USB-C Connector | =7
= Ul e—
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3. SETUP INSTRUCTIONS

Contents of the Delivery

The DPA-400 installation SW package includes the following items:

DPA-400 Setup installer (DPA-400 Setup.exe)
Firmware updater utility (UUFUpd.exe)
Latest DPA-400 firmware (*.uuf)

Release notes (DPA-400_release_notes.txt)
This manual

DPA-400 delivery also includes custom cables for monitoring DisplayPort versions 1.2 and
above and DisplayPort Alt mode over USB-C interface.

. DP to DP Y-cable (P/N 546126)
. USB-C to USB-C Y-cable (P/N 546127) (ordered separately).

Product Setup

The DPA-400 unit features an USB to serial conversion controller. Therefore, its Windows
driver will be installed as a virtual serial port named as a DPA-400 USB Serial Port. Please,
use the USB Serial Port driver installed by DPA-400 installer.

Note: System administrator's privileges are required for performing the installation.

Installing the DPA-400

In order to install the DPA-400 software and driver please follow these steps:
Power up your PC

Open the folder containing DPA-400 installation package

Run DPA-400 Setup.exe found in the installation package

vvyvyy

In the Choose Components dialog please indicate if you need the device drivers to be installed
at this time.

v

In the following dialogs, indicate the folder where the files will be installed and the Start Menu
folder for the program shortcuts.

DPA-400 software and firmware will now be installed to your PC.
Plug in the DPA-400 unit in a vacant USB port of your PC

A 4

> Run DP-Aux Channel Monitor application
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GUI Setup

In order to enable the DPA-400 graphical user interface (GUI) application to communicate
with the firmware in the DPA-400 unit, you have to set up the COM port used and provide the
license code delivered with the unit.

Selecting the COM Port Used

| 4 From the GUI pull down menu in the center of the GUI and select the serial port used for
communicating with the DPA-400. It will in most cases be named as DPA-400 USB Serial Port

Unigraf Aux channel monitor - o b

File Search Tools Filters Decoding Help

No communications port is selected.
Please, select COM port for communicating with DPA-400 and dlick "Try-connection’.
DPA-400 USB Serial Port (COM10) v

@ Try connection

Status  Error: No COM port selected 0 Bytes Buffered 0 Bytes

10
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Adding the License Key

You will need a hardware specific license key for using Unigraf DPA-400 GUI. Each license is
valid for one specific device only. By using the GUI, you can read the Seed Number of your
DPA-400 unit. For a given Seed Number, Unigraf will provide you a License Key that will
enable you to use the GUI from any PC to control your DPA-400 GUI, the user can select the
interpreted DPCD registers based on the DP version.

| 4 You can usually find your DPA-400 License Key on a sticker glued on its enclosure, in the
delivery package or among its related documents. If you cannot locate the License Key, please
email to Unigraf the Seed Number shown on the dialog in order to receive your License Key.

> Insert each of the 32 character long License Key in the field provided and click the Continue.
The license key is now saved in your PC and you can constantly use the device from this PC.
Please Click Close to return to the main window.

Unigraf Aux channel menitor - ] X
Eile Search TJools Filters Decoding Help
Please, Enter the your new license key and dick ‘Continue’.

Device Seed number

7066330b00000041
License key

-+ K H - H H H ]
Save License Continue
¥ cancel
Status  License entry Downloaded 0 Bytes Buffered 0 Bytes

11
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Upgrading the License

For upgrading your license, please select Decoding > Enter new license. In the license entry
dialog, please type in or copy and paste the new license and click Continue.

Unigraf Aux channel monitor - o
Search Tools Filters Decoding Help

7 Start acquisition Use DPCD 1.1 Decoder

Use DPCD 1.2 Decoder o
Timestamp Message details:
Use DPCD 1.3 Decoder Al -
Use DPCD 1.4 Decoder for DP 1.4a
® Use DPCD 1.4 Decoder for DP 2.0
DETAILED_CAP_INFO_AVAILABLE set to 1

+  MAIN_LINK_CHANNEL_CODING_SET set to 2 (128b/132b)
Connection independent sink / source detection

Enter new license ...

Note Please note that each Unigraf DPA-400 GUI license is bound to one specific DPA-400 unit.
The same license can be used with any number of PCs.

Note Please note that various features of DPA-400 are enabled with license keys. For upgrading
your DPA-400, please contact Unigraf.

Note The License Key never includes characters I, G, B, O because of their similarity with the
corresponding numbers. If in doubt, please use numbers. You can use copy and paste to insert
the License Key.

Note The DPA-400 must be connected to your PC for entering the License Key.

12
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DPA-400 Firmware Upgrade

When launching the GUI, it will verify that the firmware programmed in the DPA-400 unit is
matching the GUI version. If upgrade is needed the GUI will prompt the user to update the
firmware.

Please follow these steps in order to upgrade your DPA-400 internal firmware:
Unplug the DPA-400 USB cable.

> With a length of wire, short-circuit pins 1 and 6 of the digital 1/O connector. Try to make a
good contact by inserting at least %2 of bare conductor in each of the connector pin holes.

v

-l 1
5] 1
@] O O
o C=ZP
9 6
> Plug the DPA-400 USB cable to your PC.
> Locate the COM port used by your DPA-400 (for instance, COM3).

> Open Windows command prompt dialog and go to the directory where the installer copied the
firmware files. (by default c:\Program Files (x86)\UnigrafDPA-400\ Firmware). In this
directory you should find the updater, UUFUpd.exe, and the FW file, e.g. dpa-400.uuf.

> In Windows command prompt run:
uufupd -c 3 -f dpa-400.uuf

(In the entry, please substitute “3” with the number of your COM
port and “dpa-400.uuf” with the firmware file included in your
package)

> The UUFUpd utility will upgrade the DPA-400 firmware while printing a series of dots. Please
wait for its completion without removing the USB cable.

> When the message “DONE” is printed, please remove the short-circuit from the 1/0 connector
and unplug the USB cable. Your DPA-400 is now upgraded with its latest firmware.

In case you receive an error message from the UUFUpd utility, please restart the above
procedure from its very beginning (USB cable unplugged) and verify that the short-circuit you
use makes a good contact and to the right pins.

Note After a firmware upgrade, the DPA-400 USB cable must be unplugged and plugged once for
the device to be again functional.

13
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4,

DATAAQUISITION

Unigraf DP AUX Channel Monitor consists of DPA-400 unit for connecting to the
DisplayPort™ link and a Graphical User Interface (GUI) application for operating it and
creating reports. The serial communication setup and License Key entry are covered in the
Setup Instructions section of this manual. The following sections describe the process of
acquiring AUX channel data. Generating data reports is covered in its own chapter.

Getting Ready

Plug your DPA-400 to your PC and start the GUI application. Verify that the right COM port is
selected, a valid License Key is available and the GUI main window opens.

If required, connect your external input signals to the DPA-400 1/O connector using a suitable
cable.

Unigraf Aux channel monitor
File Search Tools Filters Decoding Help

4 Startacquisiion

Line Timestamp From Type Details Message details:
A

v
< >

Status  Idle Downloaded 0 Bytes Buffered 0 Bytes

Note

In order to ensure the signal integrity of high main data lane speeds (HBR2 and higher) you
will need to use the custom Y-shaped pass-by cable supplied with the delivery of DPA-400 or
the Upgrade package. DPA-400 hardware is not compatible with HBR2 and higher data
transfer speed.

Note:

DPA-400 detects the sink and source role by default from the way how they are connected to
DP Input (Source) and DP Output (Sink). When Connection independent sink / source
detection in Decoding pull-down menu, role is detected from the transaction messages.

14
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The Main Window

The GUI main window is divided into two sections. The Transaction list in the left displays
the acquired AUX channel transactions and events. The Message details panel on the right
side of the window shows the interpretation of the currently selected AUX channel transaction
line. The Start acquisition button controls the start and stop of the data acquisition. The
Status line at the bottom of the window shows the current GUI state, the amount of data
already downloaded to it and the amount of data still stored in the DPA-400 internal memory
(buffered) and waiting for downloading.

Unigraf Aux channel monitor — m] ¥
File Search Tools Filters Decoding Help

4;;’ Start acquisition Pause Download
Line Timestamp From Type Details Message details:
130 1485.60 Source Native Req RD 1 bytes from 0x00120 A | | |ine #153 - 2117.34ms
131 1485.73 Sink Native AUX_ACK - 1 bytes AUX_ACK - 9 bytes
132 1999.78 Source Native Req RD 1 bytes from 0x00120
133 1999.87 sink Native AUX_ACK - 1 bytes LT-tunable PHY Repeater
134 2011.46 Source Native Req RD 1 bytes from 0x00120 LT TUNABLE PHY REPEATER FIELD DATA STR
135 2011.58 sink Native AUX_ACK - 1 bytes UCTURE_REV [RO] -
136 2115.17 Source Native Req RD 1 bytes from 0x00000 00000 2= 0%00
137 2115.26 Sink Native AUX_ACK - 1 bytes No LTTPRs present
138 2115.33 Source Native Req RD 1 bytes from 0x0000e
139 2115.46 Sink Native AUX_ACK - 1 bytes LT-tunable PHY Repeater
0xf0001 := 0x00

142 2115.84 Source Native Req RD 2 bytes from 0x00020 No LTTPRs present
143 2115.97 Sink Native AUX_ACK - 2 bytes

144 2116.03 Source Native Req RD 16 bytes from 0x00080 LT-tunable PHY Repeater
145 2116.16 sink Native AUX_ACK - 16 bytes PHY_REPEATER_CNT [RO]
146 2116.35 Source Native Req RD 16 bytes from 0x00010 0xf0002 := 0x00

147 2116.48 sink Native AUX_ACK - 16 bytes No LTTPRs present
148 2116.67 Source Native Req RD 16 bytes from 0x02210

149 2116.83 sink Native AUX_ACK - 16 bytes LT-tunable PHY Repeater
150 2117.02 Source Native Req RD 2 bytes from 0x00090 BHY REPEATER MODE
151 2117.12 Sink Native AUX_ACK - 2 bytes 0xf0003 := 0%00

152 2117.22 Source Native Req RD 9 bytes from 0xf0000 No LTTPRs present

2117.34 AUX_ACK - 9 bytes
154 2117.47 Source Native Rea RD 1 bvtes from 0x00111 s Y | LT-tunable PHY Repeater

KAV | AME ~ALIMT DUV DEDCATED Ton1

Status  Data Ready (ldle) Downloaded 17362 Bytes Buffered 0 Bytes

Note Please note that the Filters function found in the Main Window in some previous versions of
the GUI can now be found as a pull down menu. Its function is described later in this
document.

15
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Controlling the Acquisition

The start and stop conditions of the data acquisition and monitoring of optional signals can be
defined in the corresponding dialogs. Please consult Appendix B to find out how these external
signals can be connected to your DPA-400.

Starting and Stopping Data Acquisition
By default, the data acquisition is started immediately after the Start acquisition pushbutton in
the Main window is pressed. Additional conditions can be set in the Start triggers dialog.

> Select Tools -> Start triggers. ..

By default the Start acquisition immediately option is selected. By deselecting it you can
select one or the more of the advanced options:

e  Start on the rising or falling edge of HPD signal
e  Start on the rising or falling edge of INO signal
e  Start on the rising or falling edge of IN1 signal
. Start on the rising or falling edge of IN2 signal

The acquisition will start after the Start acquisition pushbutton is pressed and when any of the
selected conditions is verified.

Start triggers X
Start acquisition immediately

Start on IN2 rising edge

Start on IM2 falling edge

Start on IN1 rising edge

Start on IN1 falling edge

Start on INO rising edge

Start on IN0 falling edge

Start on HPD rising edge

Start on HPD faliing edge

Data acquisition can be manually stopped at any time by pressing the Stop acquisition
pushbutton in the Main window. Optionally, the acquisition can be stopped automatically when
one of the enabled stop conditions is verified.

> Select Tools -> Stop triggers...
You can select one or the more of the advanced options:
e  Stop on the rising or falling edge of HPD signal
. Stop on the rising or falling edge of INO signal
. Stop on the rising or falling edge of IN1 signal
. Stop on the rising or falling edge of IN2 signal

16
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The acquisition will stop automatically when any of the selected conditions is verified.

Stop triggers *
[]5top on IN2 rising edge
[[5top on IN2 faling edge
[]stop on IN1 rising edge
[ stop on N1 faling edae
[ stop on NG rising edge
[I5top on IND faling edge
[]5top on HPD rising edge

[[]stop on HPD faling edae

Monitored Signals

In addition to the AUX channel traffic, you can also monitor the status of four digital signals.
By default, only the HPD signal is monitored. In the Monitored signals dialog, you can include
also one or more of the external digital signals INO, IN1 and IN2.

> Select Tools > Monitored signals...

The dialog allows you to select the monitored signals.

Menitored signals X
[Imonitor T2 state changes
["IMonitor N1 state changes
[IMonitor TNO state changes

[] Monitor HPD state changes

17
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Acquiring Data

>

\ A 4

Plug your source and sink devices to the DPA-400 as described in section Getting Ready of this
chapter.

Select the signals to be monitored or check that the HPD is selected.
Check the start and stop triggers.
Finally press the Start Acquisition button.

Unigraf Aux channel monitor - m] s
File Search Jools Filters Decoding Help
g Start acquisition Pause Download

Line Timestamp From Type Details Message details:

1 DPA-400  INFO Start: HPD=Low IN0=High IN1=HEY TP
2 1073.92 Unknown Event Changed:HPD=High Start: HPD=Low IND=High IN1=High IN2=High
3 1107.71 Source Native Req RD 1 bytes from 0x00201 Tnformative entry
5 1107.84 Sink Mative AUX_ACK - 1 bytes

5 1107.90 Source Native Req RD 1 bytes from 0x0000e

6 1108.00 Sink MNative AUX_ACK - 1 bytes

1108.35 Source Native Req RD 1 bytes from 0x00021

10 1108.48 Sink Native AUX_ACK - 1 bytes

11 1108.54 Source Native Req WR 1 bytes to 0x02003

12 1108.67 Sink Native AUX_ACK - 0 bytes

13 1108.70 Source Native Req WR 1 bytes to 0x00111

14 1108.86 Sink Mative AUX_ACK - 0 bytes

15 1108.90 Source Native Req RD 16 bytes from 0x00030

16 1109.02 Sink Mative AUX_ACK - 16 bytes

17 1100.22 Source 2C Req WR 1 bytes to 0x00050 MOT

18 1100.31 Sink 2C AUX_ACK - 0 bytes

19 1109.38 Source el Req RD 16 bytes from 0x00050 b

20 1100.47 Sink c AUX_ACK - 16 bytes

21 1109.66 Source 12C Req RD 16 bytes from 0x00050 I

22 1109.76 Sink 2C AUX_ACK - 16 bytes

23 1109.95 Source 12c Req RD 16 bytes from 0x00050 K

24 1110.05 Sink 2C AUX_ACK - 16 bytes

25 1110.24 Source 2C Rea RD 16 bvtes from 0x00050 b ¥

< >
Status  Data Ready (Idle} Downloaded 17362 Bytes Buffered 0 Bytes

The GUI automatically enables data download and data is displayed in the Transaction List as
soon as it is acquired and reaches the GUI. From the Status line at the bottom of the Main
window you can monitor the amount of downloaded data and how much data is still waiting to
be downloaded.

Usually, the buffered data amount always read as zero, meaning that all the acquired data has
been downloaded to the GUI. When a quick and long sequence of transactions is acquired or
when a rapidly toggling external input is monitored, the DPA-400 internal buffer can fill-up

much more rapidly than what the GUI can download.

If the DPA-400 buffer gets filled with a large amount of data, you can pause the download by
pressing the Pause Download pushbutton.

After inspecting the downloaded data, you can decide to resume the download to gather more
data by pressing the Download pushbutton.

If the acquisition is not stopped automatically by one of the selected stop triggers, you can
force its termination by pressing the Stop Acquisition pushbutton.

Note

Restarting the data acquisition clears the DPA-400 internal buffer and the GUI downloaded
data!

18
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Decoding the Data

There are multiple versions of DPA-400. All versions share the same test equipment hardware,
but more recent versions of the DPA-400 GUI support later versions of DisplayPort DPCD
register structure and other more advanced features. Please see the table below.

Version Added features

DPA-400 DPCD 1.X, HDCP 1.X decoding

DPA-400 1.2 DPCD 1.2 decoding, Sideband CH messages

DPA-400 1.4 DPCD 1.4, HDCP 2.3 decoding

DPA-400 2.0 DP 2.0 support for DPCD 1.4 decoding, including DSC, FEC and
LTTPR specific DPCD registers

DPA-400 2.1 Added eDP 1.5 support.

From the pull-down menu select Decoding and select the version.

Unigraf Aux channel monitor - a X
Fle Search Tools Filters | Decading | Help
P — Use DPCD 1.1 Decoder L
Use DPCD 1.2 Decoder
Timestamp Message details:
10 1108.48 Use DPCD 1.3 Decoder | Mors 720 - 1109478
11 1108.54 Use DPCD 1.4 Decoder for DP 1.4a AUY_ACK - 16 bytes
g ﬂgggg ®  UseDPCD 14 Decoder for DP 2.0
. EDID_DATA (Read EDID Dat
14 1108.86 DETAILED_CAP_INFO_AVAILABLE set to 1 _DATA (Rea ata)

0x00050 := 00 ff ff ff ff ff ff 00 54 c7 36 40 4c
15 1108.90 ~ MAIN_LINK_CHAMNNEL_CODING_SET set to 2 (128b/132b) 343230

16 1109.02

17 1109.22 Connection independent sink / source detection n

18 1108.31

19 1109.38 Enter new license ... N

1109.47

You can select:

DPCD 1.1 Decoder

DPCD 1.2 Decoder

DPCD 1.3 Decoder

DPCD 1.4 Decoder for DP 1.4a

DPCD 1.4 Decoder for DP 2.0

Define if DETAILED_CAP_INFO_AVAILBLE bit (DPCD 0x00005) is set to indicate that
DFP capability field is 4 bytes/port for the detailed capability description

. Define if MAIN_LINK_CHANNEL_CODING_SET (DPCD 0x00108) is set to 2 to indicate
128hb/132b Link Layer

Note

Please note that various features of DPA-400 are enabled with license keys. For upgrading
your DPA-400, please contact Unigraf.

Determining Sink and Source Role

DPA-400 detects the messages sent by sink and source by default from the way in which
connectors they are connected. The device connected to ‘DP Input’ is determined as Source
and the device connected ‘DP Output’ is determined as Sink.

When normal DP cable connection is not used, or when the direction cannot be otherwise
determined reliably, user can select Connection independent sink / source detection in
Decoding pull-down menu. In this case message source is detected from the payload of
transaction message by identifying payload items belonging to messages sent by a source and
sink respectively.
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Inspecting the Acquired Data

The data acquired by the DPA-400 and downloaded to the GUI is shown in the Transaction
list. Please refer to chapter Customizing the Main Window below for details on how to modify
the content and look of the Transaction list.

Lines

The data is organized in lines, each numbered starting from 1 and marked with a timestamp.
There are four kinds of lines:

1. Information lines
Identified by the text “INFO” in their Type column, they provide some useful information like
the time acquisition has started and stopped or the logical state of the inputs, etc.

2. Transaction lines
Identified by the text “Native” or “I2C” in their Type column, they report an AUX channel
data transfer, either a data Request or a data Reply.

3. Eventlines
Identified by the text “Event” in their Type column, they signal the state change in one or more
of the monitored inputs.

4. Sideband Channel Messages
The Isochronous Transport Service uses the sideband communications over sideband channel
(AUX CH and HPD) for the management of topology/virtual channel connection/Main Link
and performs Main Link symbol mapping.

5. Error lines
A line Type reading “Error” marks the detection of an illegal AUX channel data packet. An
irregular start condition, an irregular stop condition or transfer of a number of bits which is not
a multiple of 8 are all conditions that cause an error line.

6. Trace lines
Combines the data from several lines of a HDCP related message to one entry in Message
details panel for easier readability.

Columns

The data on each line is ordered in columns. Each column provides additional information
about the data line, facilitating its viewing and interpretation:

Line

This column displays the line number, starting from 1, and cannot be hidden.
Timestamp

Each line is identified by its timestamp, marking the instant when an event or error was
detected, or when a data transaction got started. The timestamp can be displayed as a time
delay from the start of the acquisition (absolute) or from the previous line (relative). The
timestamp can be displayed in milliseconds or in minutes, seconds and microseconds.
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From
This column indicates the originator of the data line:

e  “Source” and “Sink” for an AUX channel transaction, respectively a data
Request and a data Reply.

e  “Source Trace” and “Sink Trace” respectively for Sideband Message data
Request and Reply.

. “DPA-400” for error and information lines.
e  “Unknown” for signal state change events.
. “DPA-GUI”

. “Src. Trace”

. “Sink Trace”

3 “HDCP 2.3”

3 “HDCP 1.3”

Type
This column provides additional information about the type of the line:

. “Native” marks Native AUX channel Requests and Replies.
. “12C” marks 12C AUX channel Requests and Replies.

e  “Sideband Request” and “Sideband Reply” to mark the Sideband Channel
messages

e  “Event”is used for signal state change events.

. “INFO” is used with information lines.

e  “Error”is used for illegal conditions detected on the AUX channel.
. “Data Eror”

. “rre

. “Sb Reg”

. Sb Reply

. “Trace”

Details
This column contains an abbreviated description of the line content in textual form.

Data
The binary data exchanged during AUX channel transactions, in hexadecimal notation.

Note

Please make sure that you have connected the DP cables right:
DP Source >> DP Input, DP Output >> DP Sink Device
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Message Details

The Message details panel is used to provide a detailed explanation of the line currently
selected in the Transaction list. For AUX channel transaction lines, for each of the DPCD
memory locations affected, the panel lists:

e  All data bytes read or written.

e  All DPCD memory locations affected.

e  The name of the locations and of each of their bit fields.

e Allbit field’s numeric and binary values, together with their decoded value.
e  The Replies outcome (AUX_ACK, AUX_NACK, I12C_DEFER, etc.).

Unigraf Aux channel monitor - m] x
File Search Tools Filters Decoding Help
g Start acquisition Pause Download

Line Timestamp From Type Details Message details:

160 2118.05 Source Native Req WR 1 bytes to 0x00600 || Line #175 - 2119.74ms

161 2118.18 Sink Native AUX_ACK - 0 bytes AUX_ACK - 2 bytes

162 2118.24 Source Native Req WR 5 bytes to 0x00102

163 2118.43 Sink Native AUX_ACK - 0 bytes Link/Sink Device Status

164 2118.50 Source Native Req WR 1 bytes to 0x00108 LANED 1 _STATUS [RO]

165 2118.62 Sink Native AUX_ACK - 0 bytes 0x00202 = 011

166 2118.69 Source Native Req WR 1 bytes to 0x00600 LANED CR DOME = 1

167 2118.82 Sink Native AUX_ACK - 0 bytes LANED_CHANNEL_EQ)_DONE = 0
168 2118.85 Source Native Req WR 1 bytes to 0x00100 LANEQ_SYMBOL LOCKED = 0
169 2118.98 Sink Native AUX_ACK - 0 bytes LANEL CR DONE = 1

170 2119.04 Source Native Req WR 1 bytes to 0x00101 LANE1_CHANNEL_EQ_DONE = 0
171 2119.17 Sink Native AUX_ACK - 0 LANEL SYMBOL LOCKED = 0
172 2119.26 Source Native Req WR 5 bytes to 0x00102 - -

173 2119.46 Sink Native AUX_ACK - 0 bytes

174 2119.62 Source Native Req RD 2 bytes from 0x00202 Link/Sink Device Status

175 2119.74 Sink Native AUX_ACK - 2 bytes LANE2_3 STATUS [RO]

176 2119.84 Source Native Req RD 1 bytes from 0x00204 0x00203 := Ox11

177 2119.97 Sink Native AUX_ACK - 1 bytes LANE2 CR_DOME = 1

178 2120.03 Source Native Req RD 2 bytes from 0x00206 LANE2_CHANNEL EQ DONE = 0
179 2120.16 Sink Native AUX_ACK - 2 bytes LANEZ_SYMBOL_LOCKED =0
130 2120.22 Source Native Req WR 5 bytes to 0x00102 LANE3_CR DONE = 1

181 2120.45 sink Native AUX_ACK - 0 bytes LANE3_CHANNEL_EQ_DONE = 0
182 2136.51 Source Native Req RD 2 bytes from 0x00202 LANE3 SYMBOL LOCKED =0
183 2136.64 Sink Native AUX_ACK - 2 bytes - -

184 2136.70 Source Native Rea RD 1 bvtes from 0x00204 ¥

< >
Status  Data Ready (ldle) Downloaded 17362 Bytes Buffered 0 Bytes
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Filtering

In the Filters drop down menu you can set up rules describing which data lines are shown in
the Transaction List. You can choose the data based on:

e  The type of data line

e  The origin of the message

e  The DPCD address range

In the Filters drop down menu you can find by default a set of pre-programmed filters.

The Custom Filter dialog provides you a possibility to add and modify new filters. The pre-
programmed filters are listed in the dialog. You can copy their structure as bases of your
custom filters. It is advisable not to modify the pre-programmed filters directly but make
copies of them.

Custom Filter X

Stored custom filter definitions

Show HOCP 2.3 | New defnition
Show HDCP 1.3

Hide Native Rename selected
Hide I12C

Hide Events Delete selected
Hide Errors

Show Sideband messages only Move Up

Move Down

Filter Rules
Request / Reply Pairing mode Auto - Filter item by request if reply received within 400us of request v

A Rule Type Source Range Comment

[ Hide  Event Any(®) = Hide Events

1 Hide Other Any (%) = Hide generic or unknown items

Add ... e
¥ cancel ' Accept

In the Stored custom filter definitions panel, you will have the list of currently defined Filters.
On the right hand side buttons, you can define new Filters, rename, or delete them. You can
also reorder their appearance in the Filters pull-down menu.

In the Filter Rules panel lower in the dialog, you can review and change the Rules in the
selected Filter. By clicking Add... you can create new rules, clicking Edit... you can review
and edit existing Filters and by clicking Remove from the Filter definition.

When you click Add... or Edit... Edit Filter Rule dialog opens. In the dialog you can in detail
define the action of the rule, select the event and the event details.

You can get help by clicking Help. The “Help” text is attached to Appendix C of this
document.

Edit Filter Rule - O x

Hide ~ | |Event ~ | From | Any (*) ~ | Range:|™

[IFitter by Data:

Comment {Optional, max 120 chars): |Hide Events

& Help X Cancel o Accept
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Note Please note that Filters are a very powerful tool. They can however unintentionally hide
valuable data from you. Please be careful when applying custom filters.
A good practice is to start from an existing filter and gradually add new rules while testing
their performance.

Note Filtering and selecting the columns for display do not affect the actual data acquisition. All
transactions and their full data are always captured.

Note You can recall the default filters by deleting or renaming Filters.ini file stored in configuration
file location (default c:\ProgramData\Unigraf\DPA-400). When DPA-400 GUI is restarted, a
new Filters.ini file will be created.
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Customizing the Main Window

You can change the format of the data shown in the Transaction list and the Message details
panels in order to highlight the details of your interest.

Selecting Data Columns

You can customize the Transaction

list by clicking the right button of your mouse over the list.

From the pop-up menu, you can choose which columns to display, the style of the timestamp
and switch between absolute and relative timestamps.

Unigraf Aux channel moniter
File Search Tools Filters Deceding Help

g Start acquisition Pause Download

Selecting Font and Colors

Line Timestamp From Type Details Message details:

1108.48 Sink Native ALX_ACK - 1 bytes ~ | Line #11 - 1108.54ms

“leq WR 1 bytes to 0x02003

1108.67 Timestamp > v Show Timestamp
13 1108.70 Stie| From Timeh PRX Event Status Indicator
14 1108.86 S, ne S| Time from start EVICE_SERVICE_IRQ_VECTOR_ESID
15 1108.90 St yP Time from previous 02003 := 0x30
16 1109.02 Si ~  Details REMOTE_CONTROL_COMMAND_PENDING = 0
17 1109.22 50 Data | SEwemilEns AUTOMATED_TEST_REQUEST = 0
18 1109.31 Si Show as minsisecs.usecs CPIRQ =0
19 1109.38 St Autoscroll ~ 5 MCCS_IRQ =0
20 1100.47 Si X_ACK - 16 bytes DOWN_REP_MSG_RDY = 1
21 1109.66 S¢ Refresh F5  iq RD 16 bytes from 0x00050 I UP_REQ_MSG_RDY = 1
22 1108.76 Sin JX_ACK - 16 bytes SINK_SPECIFIC_IRQ = 0
23 1109.95 Source 2C Req RD 16 bytes fram 0x00050 b - -

You can select the font style and size used for displaying the Transaction list and the Message

details.

Select Tools -> Options ... . In the Options dialog press Select new font and choose the font

that you want to use.

Transaction List Color Options

You can select the colors for the font and background of various items.

Dptions

==

Font Selection

Selectnew font | Current font "Tahoma", size 10

Transaction list color options

Show / change color settings for:
[Normal item colors

Color example for selected item

l Change text color ] [ Change background calor ]

Highlighted DPCD address ranges

Rule #0 - RD/WR from 00050 to 00050
Rule #1 - RD/WR from 00100 to 00107
Rule #2 - RD/WR from 00200 to 00207
Rule #3 - RD/WR from 68000 to 63100

[ & Hep H X cancel H o Accept |

Transaction list color options
Show / change color settings for:

Normal item colors

Selected item colors

Highlighted item colors

Sideband request message colors
Sideband reply message colors
Signal state change message colors

HDCP 1.3 Trace colors
HDCP 2.3 Trace colors
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Highlighted DPCD Address Ranges

In order to improve the readability of the Transaction list, you can mark the AUX channel
transactions where a certain DPCD register address or address range is accessed with a color of
your choice.

v

Select Tools > Options ... . In the Option dialog press Add....

> In the New range dialog select the access type, start address and end address of the range that
you want to be colored. Press Accept.

T =
Starting from addr. (hex) to addr. (Hex)

P [ X cancel ] [ o Accept ]

Read access
Write access

> Select the range you just created from the Colored addresses ranges list and click the Font
Color and Background Color buttons to select the colors desired.

You can create multiple simultaneous coloring rules to help you get a better view of the data

captured.
Options ===
Unigraf Aux channel manitor Font Selection =N E <

Eile Search Tools Filters Decoding Help Current font "Tzhoma®, size 10
Start it Pause Download

L... Timestamp From Type Details Data Show / change color settings for:
161 0:05.707807 Source  MNatve  ReqWWR 4bytes to 0x00103 0010303000000 [Normalitem colors -] P
162 0:05.707504 Sink Mative  AUX_ACK -0 bytes 00
163 0:05.708480 Source  Native  ReqRD 6bytes from 0x00202 90020205
164 0:05.708543 Sink Mative  AUX_ACK -6 bytes 00 77 770103 00 00 Color example for selected item
165 0:05.708672 Source  Natve  ReqWR 1bytes to 0x00102 8001020000 bl
166 0:05.708768 Sink Native  AUX_ACK -0 bytes 00
[ Change text color ] l Change background color
163 0:05.708895 Sink Native  AUX_ACK -8 bytes 0010000 00 00 00 00
169 0:07.173208 Source  Natve  ReqRD 1bytes from 0x00102 90010200 _

170 0:07.178271 Sink Matve  AUX_ACK - 1bytes 00 Highlighted DPCD address ranges cl

171 0:07.173368 Source  MNatve  ReqWR 1bytes to 0x00600 8006000001 Rule 20 - RDAWR from 00050 to 00050

172 0:07.178431 Sink Native  AUX_ACK -0 bytes 00 Ruls =1 -RDMWR from 00100 to 00107

173 0:07.178688 Source  MNatve  ReqWWR 1bytes to 0x00100 80010000 02 Rule #2 - RDWR from 00200 to 00207 bl

174 0:07.178752 Sink Mative AUX_ACK -0 bytes 00 Rule #3 -RD/MWR from 68000 to 68100

175 0:07.178815 Source __Native  RegWR 1bytes to 0x00101 3001010084

:07.178880 Unknown _ Event Changed:HPD=Low

177 0:07.178912 Sink MNative  AUX_ACK -0 bytes 00 ol

178 0:07.178976 Source  Natve  ReqWR 1bytes to 0x00102 80010200 21

179 0:07.179038 Sink Native  AUX_ACK -0 bytes 00

180 0:07.179104 Source  Native  ReqWR 1bytes to 0x00107 3001070000 [(Add... | [ edt... |[Remove |[ up [ Down |

151 0:07.179198 Sink Mative  AUX_ACK -0 bytes 00 bl

182 0:07.179264 Source  MNatve  ReqWR 4bytes to 0x00103 800103030000 00

183 0:07.179360 Sink Native AUX_ACK -0 bytes 00 Color example for selected range

184 0:07.179520 Source  Native  ReqRD 6bytes from 0x00202 50020205

185 0:07.179615 Sink Mative  AUX_ACK -6 bytes 00 1111800300 00 ol

186 0:07.179712 Source___Native  ReqWR 1bytes to 0x00102 30010200 22

187 0:07.179775 Unknown _Event Changed:HPD =High €hange text color Change background color

183 0:07.179807 Sink MNative  AUX_ACK -0 bytes

189 0:07.179872 Source  Natve  ReqWWR 4bytes to 0x00103 300103030000 00 ]

190 0:07.179967 Sink Mative  AUX_ACK -0 bytes 00 [ & Heb ] l * cencal ] l o Acceot I

191 0:07.130543 Source  Natve  ReqRD 6bytes from 0x00202 90020205

192 0:07.180608 Sink Native  AUX_ACK -6 bytes 00 77 770103 00 00 TinkJGink Device Stats

193 0:07.130735 Source  MNatve  ReqWR 1bytes to 0x00102 8001020000 SYMBOL_ERROR._COUNT_LANES [14:8] [RO]

194 0:07.180832 Sink Mative  AUX_ACK -0 bytes 00 0x00217 - -

195 0:07.130895 Source  Natve  ReqRD8bytes from 0x00210 90021007

196 0:07.180960 Sink Native  AUX_ACK -8 bytes 0000 00 00 00 03 00 00 00

157 0:07.208096 Source  Natve  ReqRD 6 bytes from 0x00202  S0020205 -

4 [ . N » .
Status  Data Ready (Idle) Downloaded 4698 Bytes Buffered 0 Bytes

Note The data of Transaction List Color Options and Highlighted DPCD Address Ranges is stored
in Windows registry under
HKEY_CURRENT_USER\Software\Unigraf\DPA_400B\_ProgramConfig_. By using the
Regedit tool you can copy the settings to another PC or under another user.
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Searching for Data

You can search and highlight all lines in the Transaction list representing an AUX channel
access to a selected DPCD location.

| 4 Use Search -> Find... or press Ctrl + F. In the Search dialog select the access type and the
DPCD location address that you want to search.

The first occurrence of the found access is selected and the rest are highlighted.

Search ... @
Search for to addr. {Hex):

Any access I
Read access Q Search
Write access

| 4 After a new acquisition you can use the same search criteria and select
Search -> Find again or just press F3.
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5.

SAVING YOUR DATA

After the acquisition is stopped, the data displayed in the Transaction list can be saved to a file
in binary format or in a readable HTML format as a report. In its binary form, the saved data
can only be opened by the DPA-400 GUI while in HTML format it can be opened with any
available HTML browser.

Saving to a Binary File

From the pull down menu select File -> Save or File -> Save As ... and specify the name for
the file to be saved. You can reload a previously saved file for later inspection using File ->
Load.

The DPA-400 GUI application includes a report generator that creates a test report of the
results displayed in the Results Grid. The report is generated in HTML format and includes a
detailed description of the test steps executed, the actions taken and the causes of the pass or
failure. You can also include detailed description of the monitored source and sink and the used
TE in the report.

Creating a Test Report

The report generated by the GUI application includes all the lines from the Transaction list and
the content of the Message details panel for each of them. For creating a report select from the
pull down menu File -> Save Report ....

After selecting the report file name, in the Report Information dialog you can add a description
of the monitored source and sink devices, and your personal remarks that will be included in
the report.

Report Information — [m| X
Version Information
Unigraf AUX Channel monitor GUI version 2.1 [R0]
DPA-400 Firmware version 1.2.0
DPA-400 FPGA configuration version 1.6.0
Report Options
(®) Start from first line (O Start at line:
(®) End to last line ()End atline:

CSV Separator: l:l [Iseparate data bytes

Source and Sink information

Source device name: |

Source device details: |

Sink device name: |

Sink device detalls: |

Remarks

Report generated on 06/09/2021 13:35:25

x Cancel o Accept

28



U N l G R A F Saving Your Data

Save the report by clicking Accept or return to the main window without saving by clicking
Cancel. After the report is saved, your default internet browser will be opened to display the
report file created.

The information entered in the dialog fields will be available also for the following reports
until the GUI is closed.

Note You can create reports from previously acquired data that has been saved in binary format. Use
first File -> Load and then File > Save Report ....

Note Report creation for large amounts of acquired data can generate large HTML files and take
several minutes. During this operation the GUI will not respond to user commands. Please, be
patient.

Test Report Views

When you save a report file or open a previously saved report, your internet browser will open
the report default view.

Note how each time you select a report line the transaction details at the left shows a lot of
useful information about the data involved.

@ DP AUX Channel report L =
C @ File | Cy/Users/Tester/Desktop/Test%20Report.html T A Q

Unigraf DisplayPort AUX Channel monitor report

AUX CHANNEL TRANSACTIONS AND EVENTS REPORT DETAILS

Click entry to see details Version information
1 0.00 00 1 N

Unigraf AUX Channel monitor GUI version 2.1 [R0]
DPA-400 Firmware version 120
DPA-400 FPGA configuration version 1.6.0

Other information
Source Device: AAAA

Sink Device: BBBB

Remarks
Report generated on 06/09/2021 13:35:25
Start conditions
Immediate start
Stop conditions
Manual stop
Monitored signals

Manitor signals:
HPD
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In order to print the report, scroll down and click the Show printer friendly format...
pushbutton to get a new view formatted for an easy printing.

@ DP AUX Channel repart x o+

9 1108.35 Scurce

10 1108.48 Sink Native
11 1108.54 Source

1z 1108.67 Sink

13 1108.70 Scurce

14 1108.86 Sink Native
15 1108.80 Scurce

18 1109.02 Sink Native
17 1109.22 Source 12C

18 1109.31 Sink 12C

13 1109.38 Scurce 12C

20 1109.47 Sink 12C

22 1105.76 Sink 12C
23 1109.95 Scurce 12C
22 1110.0% Sink 12C
25 1110.24 Scurce Iz2¢
28 1110.37 Sink 12C
27 1110.56 Source 12C

g 1110.66 Sink Iz2¢
2o 1110.85 Scurce 12C
30 1110.34 Sink 12C
31 1111.14 source 12C
32 1111.23 Sink 12C
33 1111.42 Source 12C
34 1111.52 Sink 12C
35 1111.74 Scurce 12C
38 1111.84 Sink 12C
37 1111.87 Scurce 12C
38 1112.00 Sink 12C
39 1112.19 Scurce 12C

C @ File | C/Users/Tester/Desktop/Test%20Report.html

Req RD 1 bytes from 0x0000=
AUX_ACK - 1 bytes

Req RD 1 bytes from 0x00021
AUX_ACK - 1 bytes
Req WR 1 bytes to 0x02003
AUX_ACK - 0 bytes
Req WR 1 bytes te 0x00111
AUX_ZCK - 0 bytes
Reg RD 16 bytes from 0x00030
AUX_ACK - 16 bytes
Req WR 1 bytes to 0x00050 MOT=1
AUX_ACK - 0 bytes
Req RD 16 bytes from 0x00050 MOT=:
16 bytes
bytes from

. ACK - 18 bytes
Req RD 16 bytes from 0x00050 MOT=:
LUK _ACK - 16 bytes
Req RD 16 bytes from 0x00050 MOTI=.
AUX_ACK - 16 bytes
Req RD 16 bytes from 0x00050 MOT=
16 bytes
Req RD 16 bytes from 0x00050 MOT=:
AUX_ACK - 16 bytes
Req RD 16 bytes from 0x00050 MOTI=:
AUX_ACK - 16 bytes
Req RD 16 bytes from 0x00050 MOT=
LUK _ACK - 16 bytes
Req WR 1 bytes te 0x00050 MOT=1
AUX_ACK - 0 bytes
Req RD 16 bytes from 0x00050 MOT=.
AUX_ACK - 16 bytes
Req RD 16 bytes from 0x00050 MOT=1

Show printer friendly format

Show report information ..

Created with Unigraf AUX Channel Monitor

RUER-CUTS
Entry type 12C
Sent from Source

HEX Dump
50 00 50 0f

Content decoder

Line #21 - 1109.66ms
Req RD 16 bytes from 0x00050 MOT=1

Middle of transaction

EDID_DATA (Read EDID Data)
0x00050
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APPENDIX A: SPECIFICATIONS

General

Interfaces

Functionality

Operating Systems

Mechanical size
Weight
Power Consumption

DisplayPort™ Interfaces

Custom 1/O

PC Interface

Trigger inputs

DisplayPort™ signals

Real-time AUX channel traffic capturing, decoding and display.
Data store and reload in binary format.

HTML report generation.

Internal 14 MByte capture buffer.

AUX transactions as fast as 0.5 ms per transaction (Request +

Reply).
Input state changes monitored up to 8000 changes / s.
Timestamps with 32 us resolution.

Windows® 10, 8, 7

105 x 130 x 35 mm
260 grams
5V, 400 mA

One DisplayPort™ receptacle input connector.
One DisplayPort™ receptacle output connector.
AUX channel and HPD signals pass-through.

DPA-400: Main stream lanes buffered with 1:1 amplification
(maximum bandwidth 2.7 Gbps).
Pin 20 (DP_PWR) pass-through

DPA-400 1.2 and later: Main stream lanes by-passed with the
provided cable.
Pin 20 (DP_PWR) not connected

Sub-D 9 socket (female).

3 trigger inputs, link HPD signal.

4 expansion outputs.

ESD protection on all external signals.

USB interface, USB-powered.

Software upgrade capability through USB

5V tolerant.
3.3V CMOS input levels.
IEC 61000-4-2 (ESD) 8KV (air), 6kV (contact)

IEC 61000-4-2 (ESD) 8kV (air), 6kV (contact)
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APPENDIX B: /0 CONNECTOR

You can use three external trigger signals to start or stop the data acquisition. The trigger
signals are available on the SubD-9 socket connector of the DPA-400. Please refer to the
Start triggers and Stop triggers dialogs to control the triggers functionality.

The HPD_IO signal is also available on this connector to provide you an easy measurement
access to the HPD signal driven by your DisplayPort™ sink and connected to your
DisplayPort™ source device.

5 1 Pin Signal Name | Direction
O O 1 INO Input
2 IN1 Input
9 6 3 IN2 Input
4 HPD_IO Output
5 ouTo Output
6 ouT1 Output
7 ouT2 Output
8 0ouT3 Output
9 GND -

INO: external input trigger 0.

IN1: external input trigger 1.

IN2: external input trigger 2.

HPD_IO: HPD signal common to the DisplayPort sink and source devices.
OUTO0 - OUTS3: for future expansions.

GND: electrical reference ground.
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APPENDIX C: ADVANCED FILTERS

The following help text can be seen as well by clicking the Help button of the Edit Filter Rule
dialog.

Note Please note that Filters are a very powerful tool. They can however unintentionally hide
valuable data from you. Please be careful when applying custom filters.
A good practice is to start from an existing filter and gradually add new rules while testing
their performance.

Note Filtering and selecting the columns for display do not affect the actual data acquisition. All

transactions and their full data are always captured.

Data pattern expressions

A data-pattern expression is a string that describes how to determine if a data-block should be
considered as "matched"” or "unmatched". The syntax used with data-pattern expressions in
DPA-400 Aux Channel Monitor application is described below

The data-block must be covered completely by the data-pattern expression. If the data block is
shorter, or longer than the expression, then the data block is determined as "not matched". The
*' wildcard can be used to allow data blocks of any size to match.

Whitespaces and new-lines are ignored, and are allowed anywhere; White spaces and new-
lines can be used strategically to make the expression more readable.

For example: "*1(10)??(10)" is the same as "* ! (10) ? ? (10)"

Comment blocks:
Comments must be written enclosed in curly-braces '{' and '}

Wildcards
Wildcards used are "*' and '?'

? = Match any single data byte only.
* = Match any number of any data bytes. (including the possibility of matching NO data bytes)

For data matching, the byte value must be enclosed in braces '(* and ')". Use prefixes '$' to
indicate HEX value, '%' to indicate BIN. No prefix indicates DEC.

Examples:
* ($10) ($00) : Matches any data pattern that has the bytes $10, $00 at end of data.

? ($10) ($00) : Matches 3-byte data pattern that has $10 as second byte and $00 as third byte.
* ($10) * ($00) : Matches any data pattern that has $10 and ending to a $00 byte.
* ($10) * ($00) * : Matches any data pattern that has $10 and $00 after it.

($10) ? * ($20) * : Matches any data pattern that has $10 as first byte, followed by $20 with at
least one other byte in between. (i.e. will not match $10, $20)

Use '!" to invert the match:
1($00) = Match any data byte that isn't $00.

Use '?' within HEX or BIN value to ignore that bit in comparison:
($??) = ? = Any data Byte.
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($?0) = Any data byte with bits 0-3 cleared.

To match a single data byte with more than one value, separate the values with comma ;"
(0, 1, 100, 200, 254) : Matches a data byte whose value is 0, 1, 100, 200 or 254.
Invert the value group match with 'I'. Value wildcard '?* is also allowed.

Example:
1(1, 2, 3) : Match any data byte other than 1, 2 or 3.

1($7f, $f?) : Don't match data bytes with bits 0-3 set to 1, or data bytes that have bits 7-4 set.
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